Whonix VirtualBox - failed to start - NS_ERROR_FAILURE (0x80004005) - The VM session was aborted.

Edit by Patrick:

Applies to all versions of Whonix VirtualBox:

  • Whonix VirtualBox XFCE
  • Whonix VirtualBox CLI


I just upgraded virtualbox to the latest version and now i cant start whonix VMs, all other VMs are working fine.

I get this error…

Failed to open a session for the virtual machine Whonix-Gateway/Workstation-CLI.

The VM session was aborted.

Result Code:
NS_ERROR_FAILURE (0x80004005)


ISession {c0447716-ff5a-4795-b57a-ecd5fffa18a4}

I have the same problem after updating Virtualbox. Reinstalling, updating, reconfiguring kernels, nothing worked. This is problem only with Whonix, Windows virtual machine works like before.

WHAT WORKED HOWEVER was manually making Whonix by making new Debian 64 machine and adding .vdi file as a hard drive. Then I would imitate original Whonix settings and so far it works, this is how I’m answering your question.

Is it problem with .vbox file? I don’t know, importing new Whonix machines didn’t work, just manual add.

THAT SAID PLEASE ONLY DO IT IF YOU KNOW WHAT YOU ARE DOING! Who knows if I configured it correctly, it works and Workstation is fully torrified but I would consider this method as quick fix, I hope some Whonix Developer will look into it.

I’m affected by the same problem since VB was updated. Host is Linux Mint 19.1. As said above, I tried to create a new vm with same settings, same vdi file, a valid uuid, no save state, but problem persists. Tried uninstalling guest additions pack, still a no.
I’ll keep an eye on this thread

Hi Patrick, oh I missed that ! My bad, thanks for your answer and reminder

Newer solution just now documented:

Thanks Patrick!

I downgraded to Virtualbox 6.1.18 (before solution got posted) and will wait with update until it gets fixed, new version has mostly fixes not related to security.

Interesting thing because when I was updating Whonix Gateway (later just running) sound on the host would get corrupted when listening to music or playing video files. I don’t know what storage type I had in manual Whonix Gateway but if it was AHCI then this solution won’t help me. I hope it’s just temporary problem and I won’t be stuck forever on outdated Virtualbox version.

The forecast is already mentioned in above link.

A post was merged into an existing topic: Whonix live mode / amnesia / amnesic / non-persistent / anti-forensics

VirtualBox upstream bug report:
VM Machine wont to start after upgrade to 6.1.20 [archive]

According to changelog it got fixed in 6.1.22
virtualbox DOT org/wiki/Changelog-6.1#v22
Storage: Fixed regression in LsiLogic SAS controller emulation caused VM crash (bug #20323)

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]