[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

whonix-gateway not reachable

That’s it! Somehow I’ve missed your comment, but also now it happened to me and I’ve found out the same.
Configuring vif* interfaces is responsibility of /etc/xen/scripts/vif-route-qubes script called by xendriverdomain service, not udev. It fails, with logs in /var/log/xen/xen-hotplug.log. I see a single error there:

RTNETLINK answers: Permission denied

After adding set -x at the beginning of the script, I see it’s on a try to set IPv6 address. Probably because IPv6 is disabled in Whonix.
Indeed I have enabled IPv6 in my system globally (https://www.qubes-os.org/doc/networking/#ipv6). The same page explains how to disable it for particular VM (and others connected to it). So, I’ve executed qvm-features sys-whonix ipv6 '', restarted sys-whonix and now it works.

1 Like

So, I’ve executed qvm-features sys-whonix ipv6 '', restarted sys-whonix and now it works.

That explains it. I had disabled ipv6 for Whonix with the above
command several months ago.

1 Like

Is it possible (preferably) to fix this in /etc/xen/scripts/vif-route-qube? Created

for it.

That would also be an alternative solution for that could be added to Whonix salt but which than later could backfire if/when we implement IPv6 Whonix side. (although not on the horizon mid term https://phabricator.whonix.org/T509)

(related: https://github.com/QubesOS/qubes-mgmt-salt-dom0-virtual-machines/tree/master/qvm)