Whonix-Gateway Can't boot into CLI

I never had this problem on Whonix 15 and other versions.

First i can’t boot whonix gateway into GUI, i need to increase RAM from 512MB to 1024MB, otherwise i get blinking cursor…

The real problem is i can’t boot Whonix-Gateway into CLI mode. I tried reducing RAM to 256MB and i tried with rads config. Can’t get CLI login screen :frowning: Just blinking cursor, gateway works it’s routes traffic but i can’t login to it with CLI. Where can be problem ?

Known issue:

what will happen?

There shouldnt be any logins using whonix (gui&cli), So you sure you are not already logged in and you just need to use command line directly?

1 Like

Nothing. I just see blinking underscore cursor _
Grub shows up, it’s stars loading ramdisk and after that just blinking _

Is that changed on 16 version ? When i was using Whonix 15 XFCE if i lowered ram or edited rads config i was booted into CLI and there you need to enter username/password to get command prompt.

An old note on my dev page notes that bullseye will need changes to get cli mode working. Can you test the settings in the blogpost and I can commit them?

QEMU changes will likely need kernel commandline adjustment to re-enable console video mode.

Was unable to get this to work…
Created file on gateway /etc/modprobe.d/blacklist.conf with content " blacklist bochs_drm"
When starting gateway using GRUB edit (e) i added nomodeset.
But still the same, can’t boot into CLI mode.

The console viewer works OK with Whonix cli. The RAM problem is caused by XFCE moving from lightdm to gdm3 in Bullseye and that’s why it ignores rads.

We need to find some way to configure gdm3 to work with 512MB to fix this.

I’m just lost at this :frowning:
Let’s hope you or someone will find a way to have “traditional whonix RAM adjustment work” or just to boot into command line like on 15 version.
I can access whonix command line with “serial console 1” on KVM. Is this method somehow worse in security or other ways worse compared to “Spice graphical console” ?

Thank you for all your work on Whonix.
I hope one day my skill be good enough to support project.

No and is probably safer in theory.

You’re welcome.

Just for the info:
I can confirm the same problem with qemu + gateway. Setting rads-start-display-manager to 0 leads to blinking underscore without further boot progress. With DE enabled, however, boot is ok.

There’s been no issue with rads. (Elaborated in links below.)

This forum thread is a duplicate of



1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]