[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix doesn't work in VirtualBox 5.0.0

I’ll post here because my problem is related, but feel free to extract this into a new topic.

Whonix-Workstation 10 won’t start in VirtualBox 5.0.0. I know it’s a new version of Virtual Box, but it’s a stable major release, so I wonder if any work will be done to make sure Whonix 10 runs with this version. Whonix Gateway (albeit the no-GUI version) starts and runs properly. I am running the vanilla VirtualBox from Oracle, not the OSE version.

Attached is the error message I’m getting

http://postimg.org/image/b26lw192h/

This happens right after importing the official Whonix Workstation .ova file and trying to run it.

cant view the image . i was using this website before but it has problem with viewing the image.

use this website (i use it in images reports):-

http://freeimagehosting.net/

(after uploading any image , take the link of the image not the link of the website)
if u r concerns about anonymity because the servers located in US , well use free image hosting in the darknet (u can find these in hidden services wikis or …etc)

regarding Vbox+whonix:- last day i have downloaded virtualbox in my friend pc with installing whonix 10 in it. but to be honest with u i dont remember which version of the virtualbox was (didnt take the intention to look at the version of the Vbox because i didnt face any problems with versions b4 so my brain cant remember it).but it was like this : windows 8 + vbox + whonix 10 = working good.

but what do u mean vanilla from oracle ?

[quote=“TNT BOM BOM, post:2, topic:1204”]cant view the image . i was using this website before but it has problem with viewing the image.

use this website (i use it in images reports):-

http://freeimagehosting.net/

(after uploading any image , take the link of the image not the link of the website)[/quote]

Reposted image to another imagebin

I mean exactly what it means: I run the virtualbox version installed from the virtualbox installer that’s offered by Oracle here https://virtualbox.org/wiki/Linux_Downloads (see All Distributions at the bottom of the list), not the OSE version that’s usually offered through the repositories of particular Linux distros.

For now I have just reverted to using virtualbox 4.x

i have checked the version of the virtualbox it was 5 and whonix was 10

going to test virtualbox 5 + whonix 11 to if there is any problems

Greenwhonix:

The exact failure you show in your image, NS_ERROR_FAILURE (0x80004005), is discussed at some length, here:

https://forums.virtualbox.org/viewtopic.php?t=34599

More generally, when you have a problem with an error that you do not understand, do a search on the EXACT error generated. Why do that, you might ask? Because that’s exactly what all the smart Boys and Girls, do. 8)

If you cannot find relevant information, you can always file a bug report with the correct project’s developers. Again, the bug report should contain the EXACT error generated in the Bug Report Title, so others can easily find it.

However, more often than not, you’ll find you are not alone, and very often, the correct solution has already been identified.

I should also note that I am running VBox 5, and I know for a fact that the Gateways in Whonix 10, and Whonix 11, both work properly. I cannot comment on the functionality of the Workstation in VBox (yet). However, I do run many other operating systems under VBox 5 behind the Gateway, and all of them are working properly.

Hope this helps - CCP :slight_smile:

[quote=“Corrupt Correct Pig, post:5, topic:1204”]Greenwhonix:

The exact failure you show in your image, NS_ERROR_FAILURE (0x80004005), is discussed at some length, here:

https://forums.virtualbox.org/viewtopic.php?t=34599[/quote]

Aside from the fact that VirtualBox is being stupid and displays a totally useless, user unfriendly error message, which, as Linux user, I’m not used to and I don’t care to get used, for some reason you link to an ancient forum post from 2010, why? I consider this necroposting useless, considering that:

  1. Previous VirtualBox version 4.3.x is MUCH NEWER than 2010

  2. Whonix-Workstation worked fine in that version

This is not a problem with an error that I don’t understand. This is a problem with an error that nobody understands.

This is an open bait to start calling you names, fortunately for you I value this forum a lot, and I have to behave, even if I’m very tempted not to.

This is exactly what I did, it’s a problem with the Whonix-Workstation image and VirtualBox 5, since Whonix-Gateway works, as you have said yourself and I have wrote too in my original post (just in case if you’ve missed that part).

And this is exactly what I said above. The Gateway works for me, it’s just the Workstation that fails to start after being imported.

Then what was the point of your post? You could’ve tried to import the Workstation and see if you could reproduce the issue I’m having at least, it would take you a couple of minutes. That if you wanted to make some constructive contribution to this thread.

And I don’t see how’s this relevant to the particular problem with the Whonix Workstation.

seems i didnt make my message clear before sorry , vbox 5 was working with whonix 10. so i think the problem is specifically not generally.

Greenwhonix,

  1. In general, I believe in being hard on the problem, and soft on the people. Therefore, I’ll ignore your hostile, personal attack ‘style.’
  2. If and when I have time, I’ll try to see if I can replicate the issue on VBox 5.
  3. Feel free to let me know if and when you’ve regained your composure. If you require assistance with that issue, have a look a Dale’s timeless advice, available here: http://www.amazon.com/How-Win-Friends-Influence-People/dp/1508569754.

CCP

P.S. I would be remiss if I failed to disclose that I did enjoy looking at all the smoking HOT Chinese ladies accompanying your image error link - nice work!

o/ Patrick,

I have tested the Workstation 11 on VBox 5 quite extensively.

  1. I cannot replicate the error initially reported on this thread.
  2. From my POV, the title of the thread is 100% false. A correct thread would be titled; Whonix Workstation 11 IS KNOWN to work properly on VBox 5.
  3. Any even slightly experienced user of VBox should be smart enough to realize if an error or corruption issue occurs within a running VBox Guest OS, the very first thing you should try is increasing the memory allocation and or the number of CPUs exposed to the VBox Guest. That advice is certainly not just limited to Whonix Guests.
  4. I refuse to spend even one additional second of my life on the non-issue, ‘issue’ raised by this ridiculous thread.
  5. Even though the Workstation 11 runs perfectly, and (almost everything) works, there are several significant shortcomings which need to be addressed. I will start a new thread pertinent to that topic.

You should consider this case to be closed.

CCP

Hello,

Sorry for resurecting this topic, but I could not find support elsewhere.

I installed Whonix Workstation and Gateway 13.0.0.1.1 on VirtualBox 5.0.20 hosted on OSX 10.11.6 laptop about 4 days ago.

It worked just fine for 2 days, and then the Workstation started to fail the same way described above by Greenwhonix.

I tried the following:

  1. starting with “Detachable start” works, but the window cannot be brought to life after boot is completed.
  2. I upgraded to VirtualBox 5.1.10 r112026 but no improvement
  3. I bumped up memory from the default 700 something MB to 2GB but no improvement
  4. I bumped up from 1 to 2 processors; no luck

I am running out of ideas.

Could someone confirm I am not the only one on the planet facing this issue ? :slight_smile:

Just an update:

Digging a bit more in the host logs, I found that in fact the VirtualBox process spawn at start crash and dump some logs in the Mac Console. I guess this is more a VirtualBox issue.

If anyone has a workaround available, please share.

1 Like

Keeping the community updated with my researches :slight_smile:

I reimported the appliance file for the workstation and all seems good; sounds like a tricky bug on VB side.

Conclusion seems to be: not a Whonix issue, as far as I can see…

1 Like

Thanks for update.

The VirtualBox forum post linked above is not discussing the error message that OP reported. Please make sure that you are getting the EXACT same error message:

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}

The ticket linked to this error is:
https://www.virtualbox.org/ticket/15687
and discussion:
https://forums.virtualbox.org/viewtopic.php?p=369450#p369450

Sounds like a VB issue fixed in 5.1.8. Recommendation is to upgrade version of VirtualBox. (Disabling audio also appears to have worked for some.)

You can download latest version here along with checksums:
http://download.virtualbox.org/virtualbox/5.1.10/
!!! However, these downloads are not signed !!! Checksums guarantee integrity of download - they don’t verify authenticity. I don’t know how OSX package management works. I believe Oracle only offers signed .debs & .rpms.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]