[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Whonix 15 to 16 upgrade fails on GW (sdwdate : Depends: helper-scripts)

Hi,

Attempting sudo release-upgrade on whonix-gw (Non Qubes), and it is failing on sdwdate:

Processing triggers for man-db (2.8.5-2) …
Processing triggers for desktop-file-utils (0.23-4) …

  • true ‘INFO: Install pre release upgrade of dependency packages (2/2)…’
  • apt-get-noninteractive --yes --no-install-recommends install sdwdate
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

The following packages have unmet dependencies:
sdwdate : Depends: helper-scripts but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

  • true ‘ERROR: An error was encountered during download of dependency packages. Recommendation:
    Fix network connection and retry.’
  • exit 1

Any help would be greatly appreciated.

Thanks

This might be fixed in near future. Check from here:

Once I announce the new whonix-legacy package being available (which contains an improved release-upgrade script, I’ll announce that there.


Simpler alternative: Whonix ™ Factory Reset re-installation method.

Thanks very much.

I have a “lot” of user data that needs to be maintained, hence why I’m attempting the release-upgrade method (On both GW and WS).

Thanks very much Patrick - The updated release-upgrade script worked without issue on GW.


0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  • true ‘INFO: Setting a list of traditional dummy packages to automatically
    installed so these can be removed the next time the user runs apt autoremove.’
  • apt-mark auto e2fslibs gnupg2 libcomerr2 mime-support libgdk-pixbuf2.0-0 libiptc0 cryptsetup-run
  • true ‘INFO: Running sanity test (post)…’
  • dpkg-noninteractive --audit
  • true ‘INFO: Running sanity test (post)…’
  • dpkg-noninteractive --configure -a
  • true ‘INFO: Restart whonix-legacy service…’
  • service whonix-legacy restart
  • true ‘INFO: Running sanity test (post)…’
  • dpkg-noninteractive --audit
  • true ‘INFO: Running sanity test (post)…’
  • dpkg-noninteractive --configure -a
  • true ‘INFO: OK. (release-upgrade version: 1.5) Release upgrade success.’
    user@host:~$

Reloaded, ran whonixcheck and upgrade-nonroot and all appears to be functioning as expected.

(If you would like a copy of my release-upgrade log, I have kept a copy of it)

Thanks again for your prompt response to this.

Hi Patrick - Just an FYI - the updated release-upgrade script also worked without issue on Whonix WS (I also have full log output of this upgrade if your interested)

Thanks again.

Thank you for the report! Glad that worked out.

No need.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]