[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix 15 - shared clipboard and drag'n'drop not working

Hi,
after I’ve updated from version 14 to 15, shared clipboard and drag’n’drop to/from host don’t work anymore.
I rebooted several times, turning off and on again the features in Oracle VM settings, but nothing.
Host is Windows 10 Pro 64 bit, guest is Whonix XFCE.

Please help.

Thank you.

I solved by updating the guest additions:
sudo apt-get update && sudo apt-get install -y virtualbox-guest-*

2 Likes

I did, but still not solved

Hello,

I got the same problems after the last upgrade. The advice described above does not help solve this. I ask for your help!

Maybe this can help;
Make sure your using the same Virtualbox version as the Guest Additions. 6.1.2. The Guest Additions have recently been upgraded by the Whonix team, so you do not have to do anything with that. As long as your Virtualbox version on your host machine is 6.1.2 or higher, the clipboard will work. In the Virtualbox gui on the host, remember to tick the box Settings–> General, and in the “Advanced” tab 2 options: shared clipboard and drag and drop.
Also, if you have not already, update your Whonix machines:
sudo apt-get update && sudo apt-get upgrade
Also, if you have any other guest additions package installed, remove it because you do not need it.

I used the old version of virtualbox. After the update, everything works. Thank you very much.

1 Like

See:
https://www.whonix.org/wiki/Dev/VirtualBox#VirtualBox_Guest_Additions_Bugs

That’s discouraged. Old versions won’t receive security attention.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]