[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

whonix 14 disp vm

hello.

i am having trouble with whonix 14 disp vm. it says

Tor Browser is currently not installed.
(Folder /home/user/.tb/tor-browser does not exist.)
Start Tor Browser Downloader (by Whonix Developers)?

tor browser is installed. what is problem?
many many thanks.

this is not a dvm problem.

qvm-create --template whonix-14-ws --label green whonix-14-dvm
qvm-start whonix-14-dvm
qvm-run whonix-14-dvm “tor-browser”

i get the same error. but this time, its not a dvm, so it comes back with more:
ERROR: Tor not fully bootstrapped.

apparmor is on. whonixcheck is off. all instructions on the documentation wiki have been followed.

Hi veraQuin

You are using Qubes 3.2 correct?

Is Tor running in sys-whonix? Can you see if Tor is connected.

  • In sys-whonix kosole, run.

    whonixcheck

Can you try running Tor Browser without the hypen ( - ).

  • In dom0, run.

    qvm-run whonix-14-dvm torbrowser

I am using qubes 4.0.

tor is running. I can open tor onion circuits program and it is connected and I can also connect through the appvm: anon-whonix which uses whonix-14-ws as a template and sys-whonix-14 as a netvm.

but when creating a new whonix-14-vm, i get errors. whether or not it is a dvm.

running whonixcheck in sys-whonix-14:
(because I disabled everything as per instrucitions)

[INFO] [whonixcheck] sys-whonix-14 | Whonix-Gateway | whonix-14-gw TemplateBased ProxyVM | Wed Apr 18 21:37:00 UTC 2018
INFO: Skipping check_control_port_filter_running, because whonixcheck_skip_functions includes it.
INFO: Skipping check_tor_bootstrap, because whonixcheck_skip_functions includes it.
INFO: Skipping download_whonix_news, because whonixcheck_skip_functions includes it.
[INFO] [whonixcheck] Whonix APT Repository: Enabled.
When the Whonix team releases STRETCH updates,
they will be AUTOMATICALLY installed (when you run apt-get dist-upgrade)
along with updated packages from the Debian team. Please
read https://www.whonix.org/wiki/Trust to understand the risk.
If you want to change this, use:
sudo whonix_repository
INFO: Skipping check_operating_system, because whonixcheck_skip_functions includes it.

and running qvm-run whonix-14-dvm torbrowser

gives me the above error that tor browser is not installed.
i know this is not true because it works just fine in the default anon-whonix which I have changed to use netvm: sys-whonix-14 and template: whonix-14-ws.

so whonix-14-ws has a working tor browser. just not when a appvm is made from it…

Hi veraQuin

Just to recap the problems you’re having (please correct me if I misunderstood):

  • you created a (Qubes 4 ) Whonix 14 based DispVM. Creation of the VM was successful i.e. no problems
  • Whonix DispVM was started but complained there was no Tor Browser installed.
  • you hit “Yes” when prompted to install Tor Browser but a popup complained Whonix-Gateway was not connected to Tor (or something to that affect)
  • the same problems arise when you try to do the same with a AppVM

To start could you confirm that your newly created Whonix 14 (R14) VMs are in fact using a sys-whonix that is also based on R14.

The reason I ask is the problem that you are experiencing is similar to experiences other users have had that mix a R13 based sys-whonix with R14 based anon-whonix VMs. You can use this command to check the netvm of your AppVM

In dom0 terminal, run.

qvm-prefs whonix-14-dvm netvm

correct.

correct.

this only happened before I converted the vm into a dvm. after converting to dvm, clicking yes does nothing.

essentially, yes.

appvm says “tor is not bootstrapped”
dvm does nothing after clicking yes to download tor browser.

[root@dom0 ~]$ qvm-prefs whonix-14-dvm netvm
sys-whonix-14

i have whonixvms: sys-whonix, sys-whonix-14, whonix-ws, whonix-gw, whonix-14-ws and whonix-14-gw.

the whonix-14 vms were made by upgrading whonix vms as per

i think this is a qubes issue. it does not make sense that default anon-whonix would work after changing netvm and template, but new vm will not run torbrowser.

========================================================
update

to be clear: netvm is always sys-whonix or sys-whonix-14
and template is always whonix-ws or whonix-14-ws

i had idea. i thought to make a copy of anon-whonix, which was original vm from install but changed netvm and template. it always worked.

make copy of it and convert it to dvm using qubes commands:
[user@dom0 ~]$ qvm-prefs anon-whonix template_for_dispvms True
[user@dom0 ~]$ qvm-features anon-whonix appmenus-dispvm 1

first i tried to change my whonix-ws-dvm to netvm and template whonix-14’s.

yesterday, doing this gave errors from above. today, this works.

??

i have 4 whonix-##-appvms. whonix-ws-dvm, whonix-14-dvm, anon-whonix and anon-whonix-14.

-anon-whonix works with whonix 14 and 13. (netvm and template) (default qubes installed)
-anon-whonix-14 does not work with whonix 13 or 14… I installed this.
-whonix-ws-dvm works with both 13 and 14. (but it did not work with 14 yesterday? maybe i am mistaken…) (default qubes installed)
-whonix-14-dvm works with 13 but not 14. (i made this one)

anything above that “does not work” is saying “tor browser not installed/download with tor downloader by whonix”

very strange. completely random. i am very sure that my netvms and template are set correctly.

all in all… whonix-ws-dvm works now, so i do not need further assistance. i can work with that. i should be able to make a copy of it instead of making one.

correct. making a copy of whonix-ws-dvm allows whonix-14-dvm…

I would not recommend doing this if you have already used anon-whonix to visit websites. If anon-whonx has malware all the DispVMs will as well.

Not sure I understand “change my whonix-ws-dvm to netvm”

Your post is a little hard to follow. However, if you look at all the VMs that do not function correctly there is one common theme:

“I installed this” or “I made this one”

The error that you are getting commonly occurs (note: not exhaustive list)

  • when there is a networking issue between the anon-whonix (dvm in your case) and sys-whonix
  • when sys-whonix can not connect to Tor
  • sys-whonix-13 is netVM for anon-whonix-14
  • issue with GPG verification

What to do?

  1. Simplify things as much as you can. Keep in mind Whonix 14 is still in testing so it might be a good idea to get things working in Whonix 13 (complete all the steps) then mirror those same steps for Whonix 14
  2. To simplify even more, use sys-whonix-13 as netvm for anon-whonix-13. Do the same for Whonix 14 based VMs. Do not mix VMs until after you have them working i.e. do not mix Whonix 13 and Whonix 14 VMs
  3. If you change the netvm of a running VM, sometimes it is necessary to restart the VM for the networking to function properly.

From what I can gather, some VMs work others do not (the ones you created). Its likely a user mistake. (I’ve been wrong before though :smile: )

I’d be happy to help if you have any more issues. If so could you post all steps you used to create VMs . Also preferences i.e qvm-prefs netvm etc.

1 Like

Yes, I type like a scatterbrain. hahah.

ok. it works if i make a copy of dvm installed by OS.
does not work if i create one from scratch.
it would be very helpful to know what i am doing wrong or if this is a bug and how to fix.

i follow steps on qubes-os.org for creating a dvm.


[user@dom0 ~]$ qvm-create --template whonix-14-ws --label red whonix-14-dvm
[user@dom0 ~]$ qvm-prefs whonix-14-dvm template_for_dispvms True
[user@dom0 ~]$ qvm-features whonix-14-dvm appmenus-dispvm 1

i use the gui to set my netvm to sys-whonix-14.

i created whonix-14-gw and whonix-14-ws by creating a copy of whonix-gw and whonix-ws and upgrading them as stated on whonix.org.

After this command did you down load Tor Browser in the whonix-14-dvm ?

2. qvm-prefs whonix-14-dvm netvm sys-whonix-14

3. qvm-run whonix-14-dvm torbrowser

4. Then follow the prompts. Once you have Tor Browser installed in whonix-14-dvm, shut it down.

5. qvm-prefs whonix-14-dvm template_for_dispvms true

6. qvm-features whonix-14-dvm appmenus-dispvm 1

I wrote up step by step instructions on how to install and configure from the Whonix 14 templates in untrusted. Please let me know if they should be edited!

1 Like

@0brand : i did not download tor browser.

i had used my work around for a few weeks and i tried to make a new dvm after the latest qubes updates.

everything seems to be working normally now.
not sure if i mentioned this earlier, but i was wondering if restarting the pc would fix this problem. i had 1/2 success with this. but i did not test it fully to see if that made the difference.

either way, it works normally now.

thanks for your help!

@awokd : thanks for that write up! i am going to test it out. i think its more ‘accurate’ to use a template from the repo than a template upgrade from 13 or an upgrade from fc26 to 27 to 28 and so on.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]