[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Whonix 14 and TorGuard VPN

vpn

#62

I have found some bugs in my setup. Now after reload i don’t have to apply any setting over and over again. OpenVPN works out of the box and connects sucessfully. But i still unable to run apt-get update/install command.

asd3333, what are the DNS settings are there in your /etc/resolv.conf ? Instructions say it should contain my VPN DNS servers addresses, but i cant set that addresses. My resolv.conf has 1.1.1.1 and 1.0.0.1. If i change to my VPN DNS and try restarting resolv.conf via /etc/init.d/resolv restart - my DNS are still 1.1.1.1

My DNS are always 1.1.1.1 and 1.0.0.1 somewhy, i tried many different “how-tos” to set DNS, anyway after reboot my /etc/resolv.conf always 1.1.1.1 and 1.0.0.1
Why !?!?!?


#63

According to nslookup run i have finally edited DNS setup to match my VPN providers servers. Still same error… Can’t run apt-get update…


#64

You’re not supposed to edit this file - just to check it in order to make sure it’s being written by resolvconf and does not include something like the whonix default (before installing resolvconf it includes 10.152.152.10).

How does resolvconf locate the VPN provider’s DNS and writes it to the file - sorry I have no idea.


#65

What VPN provider do u use ? I will try it as well. What are the dns servers you have set in /etc/resolv.conf ?


#66

I know. I edited correct one: /etc/resolvconf/something/head(base) just to give a try. nslookup shows another DNS address but sudo apt-get not working as before


#67

/etc/openvpn/openvpn.conf

  • up "/etc/openvpn/update-resolv-conf script_type=up dev=tun0"
  • down "/etc/openvpn/update-resolv-conf script_type=down dev=tun0"

should handle that.


#68

asd33333, What VPN provider do u use ? I will try it as well. What are the dns servers you have set in /etc/resolv.conf ?

Any suggestion how do i fix my problem ?


#69

I have made a new clean install of last VirtualBox + downloaded last version of Whonix 14.0.x.x.9.9 or something like this.

Same result. Ping works, nslookup/websites works, apt-get - unrecoverable error in name resolution …


#70

Hi Denssss

I doubt this will help. Actually very doubtful. But you can try.

Set your VPN providers DNS then run.

chattr +i /etc/resolv.conf


Did you follow: (deactivate stream isolation for apt?)

Did you search the Whonix forum for your error messages?

Something wicked happened resolving


#71

yes, i folowed deactivation of stream iso for apt… no difference. it’s just so strange behaviour, cuz everything else works good…

may be some1 can tell me 100% working VPN provider in this scheme, i mean tested VPN provider.


#72

@rob75

Any interest in looking over this thread? OP conigured VPN and works except for updates (apt-get …) from the VPN VM . Other VM without VPN apt work fine. Any ideas?


#73

Try mullvad. This setting works with them and you get 3 hours for free to try it out before making any payments. No registration / email / anything necessary either.


#74

But is it torguard ok and easy if you just want to use the tor browser like this “Tor - VPN - Internet”? That is what i want.

If you also want to use something else, i guess you need this vpn anonymous-vpn.biz
here are the instructions https://www.youtube.com/watch?v=nwO31AxfCJM

what do you guys think of this vpn?