Unknown splash screen logon


Hi everyone !

I’m new to whonix and after a very little time using this awesome OS, actually just the time to set up everything, each time I try to reach either the gateway or the workstation I keep getting this unknown logon splash screen which no username/password combo that I know works.

I’m using minimal debian x86 (yeah…old computer) up to date and virtualbox version 5.0.26 r108824

The problem is that I used keepassx, and right before I make any backup of the database I had this issue so I don’t have any of my username/passwords combo to access my account on the web.

thanks for your help

Login Prompt After Upgrade

Possible duplicate:

Default credentials are listed here https://www.whonix.org/wiki/VirtualBox:

The default username is: user
The default password is: changeme

Did you update Whonix 12 to Whonix 13 or download and install a new version of Whonix 13?


oops sorry for duplicate issue I tried to search but not enough obviously, and I forgot to mention that I already tried the default credentials. I checked the older ticket and I have the same critical KDM’s error.
So if I understood I need to upgrade whonix from 12 to 13 right ? Or am I still missing something

Edit : wasn’t aware about version 13, I just figured out I’m still running whonix 12, I just updated from command line within the OS, I realize now that I have to check the forum sometimes

btw thanks for your quick reply


can you please tell me the path to KDM’ logfile as the upgrade from whonix 12 to 13 has to be done from the terminal within the OS but I can’t reach the OS, I keep getting this error screen after using the default credentials, I tried also root with my password and I had same critical error telling me to check KDM’s logfile



I don’t think that log helps. Anyhow: /var/log/kdm.log

You can try login to a virtual console:

Then try to fix the broken dependencies.

sudo apt-get update
sudo apt-get install non-qubes-whonix-gateway

It is probably a lot easier to just install a new Whonix 13 Whonix-Gateway rather than trying to fix a broken Whonix 12 -> Whonix 13 upgrade.

not able to log into Whonix in Virtualbox

ok thanks a lot, but I need my keepassx database to get my credentials back I really need them, without this database I can’t reach my forum accounts and some webmails as well, really unfortunate for me. some of these forums are private ones, so without credentials nor access to my emails I loose everything. so I have to try, anyways thank you for your hard work and availability. I should have done a backup on my debian, my bad…

cheers Patrick


Well, you won’t need an old Whonix-Gateway for that. Unless you stored keypass in Whonix-Gateway?

You probably have in the workstation? So why not concentrate on the workstation?


yes you’re right, that’s exactly waht I’m doing right now :slight_smile: now that I know that this version is obsolete. I trid many times before to reach only workstation but I have the same issuee


So the workstation has the same issue?


I see.


So first of all, make a backup of the thing you want to recover so it does not actually get worse by what you are trying. VirtualBox export…


Oh I though it was clear, yes I have same issue on both stations, actually I reach sometimes the OS like right before I opened this ticket, and I was able to do a successful update of the gateway but when I did a reboot same issue again, so to be accurate, this problem happens like 98% of the time, that’s why I’m keeping them with the hope to reach the OS normally.


Then try what I said here Unknown splash screen logon (in combination with a Whonix 13 Whonix-Gateway).

Or if that does not work, alternatively you can access the VM disk image file from the host. Try to figure out how to mount a vmdk with your host operating system. Or convert the vmdk to vdi first and then mount the vdi file with your host operating system. Once it is mounted you can extract any file you desire. Since it is undocumented unfortunately, researching that is up to you.

Recovering data from vmdk (or vdi) files is not specific to Whonix as per:


Needless to say, not easy.


well thanks a lot, sounds good to me, even though I imagine it’s not easy work but I’ll try that, seems to be a good work around, and hopefully if I succeed I’ll post here screens :smiley:

thanks very much


Hi everyone,

I have the exact same problem that is probably linked to the apt-get autoremove I did on both the gateway and the workstation.
I did not do any whonix update appart from the usual sudo apt-get update && sudo apt-get dist-upgrade.
Next reboot I was locked out.
Following your advice I managed to open a virtual console and could log in with my current login and pass.

sudo apt-get update && sudo apt-get dist-upgrade do not find anything missing yet something definitely is.

I have very important information on the workstation that I cannot afford to loose, i’m totally freaked out right now.

When you say :

Then try to fix the broken dependencies.
sudo apt-get update
sudo apt-get install non-qubes-whonix-gateway

If I do that with the correct command for the workstation, will it delete my data ??? I did use the export appliance like you recommended.

It seems all the data is untouched and it is probably trivial to get it back for a power user but I’m totally lost right now.

Edit :

I followed your advice on the gateway and it works like before. I have no personal data on it so I have no idea if anything was deleted from it or not. I would guess not as login and pass did not change and keyboard layout is back to what it was.
I will wait for confirmation that it is safe for my data to do the same thing on the workstation.



But it is good to have a backup indeed generally you never know (hdd failure w/e).


Omg I’m saved, thanks a lot Patrick, you can’t believe how releived I’m right now !

All is running fine now.

Take care !!