[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Unable to retrieve Tor settings

whonix 10 , workstation , trying to apply i2p with tor according to this link:-

but i cant do this step:-

Add http proxy IP: 127.0.0.1 port: 4444 in Tor Browser's Tor Button settings.

because when i press on open network settings it says:-

unable to retrieve Tor settings Please insure that Tor is running

image:-

and i dont know what is exactly in tor which is not running because i can smoothly browse it

Tor Browser version 4.0.8 or 4.5?

As per https://www.whonix.org/wiki/Tor_Browser#Change.2FRemove_Proxy_Settings

Forget about Tor Button's -> Open Network Settings. See footnote, if you want to know why.[32]

For Tor Browser version 4.0.8, does https://www.whonix.org/wiki/Tor_Browser#Change.2FRemove_Proxy_Settings help?

In 4.5 they removed that menu. You can try if the usual Firefox proxy settings menu works or if that’s broken upstream.

yeah it was 4.0.8 , now i have updated the browser , and yeah the tor settings not there , but the question now how to do the i2p step then?

yeah i went to:- preferences -> advanced -> network -> settings -> and i put in the field called HTTP proxy = 127.0.0.1 port 4444

but the same message for any i2p website = “Unable to find the proxy server”

why dont we add i2p.list in /etc/apt/sources.list.d and then we can install i2p like any debian installation guide ? look at their instructions: (btw i cant add new file in the above path)

image:-

[quote=“TNT BOM BOM, post:6, topic:1062”]why dont we add i2p.list in /etc/apt/sources.list.d and then we can install i2p like any debian installation guide ? look at their instructions: (btw i cant add new file in the above path)

image:-

http://i.imgur.com/fudCSWV.jpg[/quote]
Because we then we would totally trust them with all packages. Their system being broken could infect all Whonix users using that repository. Issues with that repository would be reported here and others would suggest to remove it.

[quote=“TNT BOM BOM, post:5, topic:1062”]yeah i went to:- preferences -> advanced -> network -> settings -> and i put in the field called HTTP proxy = 127.0.0.1 port 4444

but the same message for any i2p website = “Unable to find the proxy server”[/quote]
Mind doing the “try reproducing it on plain Debian” way?

Because we then we would totally trust them with all packages. Their system being broken could infect all Whonix users using that repository. Issues with that repository would be reported here and others would suggest to remove it.

yes totally agree with u.

Mind doing the "try reproducing it on plain Debian" way?

yes i will , but not exactly now because its almost 4 am and i have to wake up at 9 so u know … , i will give the results 2morrow. thnx :slight_smile:

i have followed these instructions from their website:-

https://geti2p.net/en/about/browser-config

but the result is the same , image:-

so i think its their problem with this proxy ; but do u have any other method to make i2p connection from whonix-workstation? or there wont be till they fix that ?

Leave Whonix out of the equation for now.

Step 1) Debian + iceweasael + i2p working.

Step 2) Next step is getting Debian + TBB + i2p working.

Until you are at that point, you can contact upstream projects, i2p, TBB and ask for help.

Once you figured out the issue, try the same on Whonix. Most likely it will work by then.

yes im in the progressing of that , i will firstly install the i2p on a windows inside the VM for ease to contact their forum if anything went wrong , then i will install it in debian (not browsing configure) , and i will install TBB on debian and try to connect it with i2p to c if its going to work.

i will give the feedback as soon as possible. 8)

hi there , i have tried all possibilities which r :-

-i2p + iceweasel + debian (without installing i2p, just iceweasel proxy config with i2p ) = not working

-i2p + tor browser + debian (without installing i2p, just tor browser proxy config with i2p) = not working

  • ^^^^ also same for whonix

but

-i2p + iceweasel + debian + installing i2p + iceweasel proxy configuration with i2p = working

-i2p + tor browser + debian + installing i2p + tor browser proxy configuration with i2p = working

i asked in their forum that if the installation of i2p is a must to make it work or not, and im waiting for the answer. but im sure it needs to be installed first then browser proxy config, otherwise it wont work with just browser config.

-i2p + iceweasel + debian (without installing i2p, just iceweasel proxy config with i2p ) = not working

-i2p + tor browser + debian (without installing i2p, just tor browser proxy config with i2p) = not working

  • ^^^^ also same for whonix

Not surprising at all.
-i2p + iceweasel + debian + installing i2p + iceweasel proxy configuration with i2p = working

-i2p + tor browser + debian + installing i2p + tor browser proxy configuration with i2p = working


Expected.
i asked in their forum that if the installation of i2p is a must to make it work or not, and im waiting for the answer. but im sure it needs to be installed first then browser proxy config, otherwise it wont work with just browser config.
From a technical viewpoint it is obviously required.
From a technical viewpoint it is obviously required.

yes , it has been confirmed from their forum.

Were able to solve your original issue?

no its blocked by whonix , here is what i did:-

1- i have installed “gksu” (because its not installed by default in whonix)

2- i have installed leafpad to ease of editing (or any editor file)

3- typed this command:-

4- inserted the password and add these 2 repository (the binary and the souce code) since we r in wheezy so we gonna use:-

deb http://deb.i2p2.no/ wheezy main
deb-src http://deb.i2p2.no/ wheezy main

5- save&exit

6- downloaded this key:- https://geti2p.net/_static/i2p-debian-repo.key.asc

7- use this command to add the key:-

8- then update by the command:

9- now install i2p.keyring by typing:-

10- going to the konsole and i have typed:-

many apparmor denial messages have been acquired from the notifications , and tor never started after this command “i2prouter start”. (it shown to be started/work in basic debian+iceweasel, but not in whonix dont know why)

here r the messages in this topic:-

https://www.whonix.org/forum/index.php/topic,1220.0.html?PHPSESSID=59jlvh09skt3j15g6i56rht95s2ulhhi

*note:- from step 3 to step 10 instructions found to be in the original i2p website https://geti2p.net/en/download/debian

I am not convinced yet, that this is Whonix’s fault. The only difference in Whonix is, that apparmor is enabled by default. When upstream (here: i2p) ships a buggy apparmor profile, this is to be expected. For the apparmor issue, let’s move over to the apparmor thread.

thats true it might also i2p fault for not configuring their program to run side by side witha apparmor.

but i meant in comparison of debian+iceweasel/tor & whonix+tor , here is what happening.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]