Unable to connect to internet from within Whonix-Workstation-based AppVMs [Qubes 3.2]

Hey everyone,

I am a long-time user of Whonix and Qubes 3.2. The following issues are specific to the Whonix Workstation on Qubes 3.2.

Firstly, I should start by saying that I ran into the updating problems with the onion repositories. I fixed those by commenting out the onion addresses in the Whonix Workstation TemplateVM (I didn’t have to do this with the Gateway TemplateVM, which didn’t cause me any problems for some reason).

Unfortunately, I am still unable to access the internet from any of my Whonix-ws-14-based AppVMs, and this has been a problem I have been having since the last update. Here’s what happens:

When I first open the Tor Browser, I receive a warning that my activities may be linked if the Tor Browser is already running. I have gotten this sort of warning in the past when I already have an instance of the TB running, but that’s not the case here.

I click “yes” to get rid of the warning box and the Tor Browser proceeds to open. The first sign that something is (still) not right is that it’s unable to find the local Whonix splash page file that always pops up when the browser first starts. Weird, but certainly not a huge issue.

Then, when I try to do a random search (I use DDG’s Onion service to conduct searches), I’m told that the server has reloaded while the request was being made (or something to that effect; it’s a super-common error message). Whatever the cause may be, the result is that I’m unable to visit any website; Google, DDG Onion, DDG Clearnet, and so on all give me the same error.

It occurred to me that this might be a Tor Browser problem, so I opened up the Electrum bitcoin client in the same AppVM to see if that works. Unfortunately, Electrum doesn’t connect either.

Then—again in the same AppVM—I open up konsole and ping google (both google.com and Interestingly, when I ping google.com the terminal shows me the site’s corresponding numerical IPv4 address, so there must be some sort of DNS access at the very least, right? Anyway, aside from seeing the IPv4 address I get no feedback whatsoever for the next 20-30 seconds, so I finally Ctrl-C the process and see a packet loss of 100%.

Finally, I open Firefox in my “Untrusted” AppVM, which uses Fedora 28 as its template and sys-whonix as its NetVM. It takes me to Google without the slightest problem.

Any ideas? Is this just a bad update I’m going to have to wait out, or are there steps I can take to remedy the situation in the meantime? 90% of my Qubes work is done on Whonix, so this has been a major hit to my productivity.

Any help would be greatly appreciated!

Have you upgraded to Whonix 14?

cat /etc/whonix_version

(should show 14)

What does whonixcheck say in sys-whonix and anon-whonix?

Might want to run with:

whonixcheck --verbose

in Konsole for detailed output.


Yes, I have. I downloaded entirely new templates rather than upgrade from within the TemplateVMs. My Workstation and Gateway TemplateVMs are called “whonix-ws-14” and “whonix-gw-14,” respectively. I’ll post the exact output in just a sec (I’m typing this from a different machine).

Okay, so cat /etc/whonix_version returns 14 on both sys-whonix and anon-whonix, which is great.

I don’t see anything out of the ordinary when I run whonixcheck --verbose on sys-whonix. BUT when I try running it on anon-whonix, I get bash: command not found.

I remember a lot of stuff got autoremoved after updating to Whonix 14. Could it be that stuff that shouldn’t have been removed went with it?

Could be. In anon-whonix / whonix-ws-14:

dpkg -l | grep qubes-whonix-workstation

Should include:

ii qubes-whonix-workstation 3:7.9-1 all Default packages for Qubes-Whonix-Workstation

If it’s not there would explain why whonixcheck is missing.

Easiest, non-experts: On Qubes-Whonix-Workstation package qubes-whonix-workstation should stay installed. See also:

You might have been hit by this bug which lead to excessive autoremove:


Indeed, dpkg -l | grep qubes-whonix-workstation returned nothing. I’m installing it right now. Will update as soon as it goes through.


That was the problem. The qubes-whonix-workstation package wasn’t installed. I’m able to connect to the internet again, and the splash page has returned as well.

1 Like