[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Tor.pid

I’m not sure 100% where to post this since I’m using Whonix inside of Qubes, so I’m also crossposting this into the Whonix forum.

I’ve switched over to Whonix 9, and I’ve run into this problem. When I first install it, everything runs fine. As soon as I shutdown and restart at a future time, I lose the ability to connect through tor.

It tells me: “there is no /var/run/tor/tor.pid”
“starting tor daemon…aa-exec: ERROR: profile ‘system_tor’ does not exist”

I looked around to find any solutions to my problem, and the only thing I could find was an old github comment saying this bug was fixed in whonix 8.

Hi QuestionMaster,

Currently, there are a number of ways that Whonix doesn’t work in Qubes, if procedures are not done strictly and correctly. So it may just be a simple user error like this.

For example, I’d look in this order:

  1. You have to ALWAYS startup your Whonix-Gateway and Whonix-Workstation from the dom0 Terminal using the (qvm-start --custom-config) commands listed on the Whonix Qubes wiki page. Starting it with the Qubes VM Manager like other VMs will leave you without Tor internet access.

  2. In your Whonix-Gateway, go through the “whonixsetup” configuration again. Either click the shortcut on the desktop or enter “whonixsetup” on the command line.

  3. Make sure your Qubes firewall settings are all good for firewallvm, gateway, and workstation. Make sure the forwarding between Whonix VMs is active in the firewallvm terminal using “sudo iptables -L”, which should forward both ways between 10.152.152.10 and 10.152.152.11.

  4. After installing, you cannot flexibly change things around, such as VM names, firewallvms, ip addresses, etc. If this was the case, then you need to at least go back and recreate the custom configuration files as well as maybe update the network settings inside the Whonix-Gateway and Whonix-Workstation. If it gets too confusing, then starting the setup from scratch again might be easier.

It honestly sounds like a simple user error somewhere, where your networking configuration is getting screwed up.

Currently, the Qubes + Whonix implementation requires real user strictness with all the steps and settings.

Beyond that, if the problem continues, even with a clean install, then it would take further diagnosis.

But, since it was working for you, I’d guess that one of these user errors is the issue.

This very issue is likely not caused by Whonix Qubes. Crosspost answered here:
https://www.whonix.org/forum/index.php/topic,563.0.html

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]