TOR not starting after Whonix 14 manual upgrade

Had a perfectly fine Whonix 13 running in VirtualBox on MacOS 10.13.6 when forced to update to 14 today.

On booting into 14 I get this:

whonixcheck fails Tor Pid Check Result Tor not running (tor_pid)message: Pid file /var/run/tor/ does not exist.)
Applications:System:Restart Tor reports “Failed to start Anonymizing overlay network for TCP.”

First upgraded VirtualBox app and the Oracle addons, no drama.

Followed step by step the manual upgrade directions for non-Qubes Whonix - last updated Oct 22 2018

Started with workstation, then did gateway. Once the workstation finished downloading apt-get-noninteractive dist-upgrade, I started the gateway update.

Same thing happened on both: All fine until after the final step sudo apt-get install --reinstall virtualbox-guest-* I go to save Konsole output and KDE immediately crashes. Reboot the virtual machines and TOR no longer works as described above.

I’ve seen other threads like this, but none of the solutions make any sense to my mid-level UNIX head. Could you please summarize the solution for me?

Hi blackheart

Can you try this please:


1 Like

Thanks 0brand. Tried it, did not fix; same result.

Here’s current perms:
drwx--S--- 2 debian-tor debian-tor 4096 Nov 16 23:35 tor

Tor - Whonix

Tor - Whonix