[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Tor circuits are dissapearing every time in Whonix-Gateway

Hi. The problem is very strange. When I start Whonix-Gateway, no Tor circuits are build at all. When I open logs, I see “general SOCKS server failure error”. Bootstrap hangs on 50%. When I open Tor Control Panel and tap “Restart Tor”, bootstrap passes fine with 100%, but in some time (in 20-60 minutes) all onion circuits are becoming disappeared. I need to restart Tor again, again and again to make it work for some time. Note: I’m using obfs4 bridges with Tor on Whonix-Gateway.

But the fun fact is that in Tor Browser Bundle, on host OS I’ve never faced this problem, and everything works fine. Only in Whonix. So, may be it’s problem with tor core package in Whonix-Gateway or something like that? Can you help me please to solve that annoying problem?

Try compare Tor configuration of Tor Browser Bundle (TBB) versus system Tor configuration on Whonix.

Nothing specific. The configs are completely defaults both for TBB and Whonix-Gateway. I tried both with default obfs4 (recommended) bridges and custom obfs4 bridges from bridges.torproject.org. I’m facing with this problem from time to time only in Whonix.

I mean to say configuration files.

Try compare Tor configuration files of Tor Browser Bundle (TBB) versus system Tor configuration on Whonix.

Setting up with GUI is OK. But please look at the resulting configuration files. Compare.

Please post the two different resulting configuration files here. Redact IP addresses/ports.

There are a lot of Whonix-Gateway Tor configuration files linking into one Tor config with #include directive. What is the name of resulting tor config file I need to post here?

Whonix: only /usr/local/etc/torrc.d/40_tor_control_panel.conf

Tor Browser Bundle torrc also required.

Whonix-Gateway /usr/local/etc/torrc.d/40_tor_control_panel.conf:

DisableNetwork 0
UseBridges 1
ClientTransportPlugin obfs4 exec /usr/bin/obfs4proxy
bridge obfs4 IP:PORT Fingerpring
...
...
bridge obfs4 IP:PORT Fingerpring
The end.

TBB on host OS torrc config:
Bridge obfs4 IP:PORT Fingerprint
...
...
ClientOnionAuthDir $PATH
DataDirectory $PATH
GeoIPFile $PATH
GeoIPv6File $PATH
UseBridges 1
The end.

Are the bridge obfs4 lines any different? Using different IPs / ports / fingerprints / anything?


Better use these code tags:

```
text
```

Yes, obfs4 IPs/Fingerprints are different both on TBB on host OS and Whonix-Gateway. Should I try to use the same bridges in Whonix-Gateway that I use in TBB on host?

Yes, please try.

Well, I tried using the same bridges but it’s still disappearing. But now I tried to enter only one custom obfs4 bridge in Tor Control Panel Config and it’s been working for the whole day now without disappearing. I don’t know why, but it seems it’s somehow connected with bridges. Some obfs4 bridges don’t work stable for me. So I needed to find the one which works well. Any idea why this happens?

Btw, is it safe to use Tor with only one obfs4 bridge entered in config or I need to provide several obfs4 bridge lines? Using Wireshark I noticed that Tor uses 1-2 bridges IP anyway even if I provided more.

Unfortunately, not.

See:

Best to ask The Tor Project support. As per:
https://www.whonix.org/wiki/Support

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]