Tor Browser isn't working

I’m having trouble getting the Tor Browser to work in the Whonix Workstation. I have close to default settings, with the workstation being routed through the internal network created by a virtualized gateway. I have internet connectivity via the terminal and Tor seems to be working properly but I cannot get the browser to work. I get a message saying “The proxy server is refusing connections” when I try to connect to a website. When I tried turning off the proxy settings in the browser, I got a message saying “Unable to find proxy server”. Does anyone know how to fix this issue?


No idea, but the net tells me it almost always relates to control / socks port configurations. :wink: Sometimes gateway connection problems e.g. not fully bootstrapped too.

A previous Tor Browser release e.g. 6.5a4 was blocked with the same error, and Patrick had to play around with anon-ws-disable-stacked-tor to get it working. e.g. see here:

I’m sure one of the experts here will ask: standard Whonix or Qubes-Whonix & what does WhonixCheck say? That might help to identify the problem by running WhonixCheck in verbose mode in both the gateway and workstation (via the terminal).

Also, when you say “close to default settings”, maybe something you changed is causing a conflict?

Since Whonix users aren’t reporting problems en masse, it is unlikely to relate to the recent Tor Browser release and some incompatibility with system Tor in Whonix, or some Whonix update bug.

Now I’ll butt out and let one of the experts deal with this…

This may also relate to your issue:

If, for whatever reason, the user wants to disable the Tor Browser from connecting to their local Tor daemon (such as to prevent tor-through-tor with forced transparent torrification, or use the Tor Browser for it’s security rather than it’s anonymity, or point the Tor Browser to an SSH SOCKS proxy), they will find that since the release of the Tor Browser 4.5.1, it will fail to connect to any SOCKS proxy that isn’t a Tor daemon, and it will complain saying, “Firefox is configured to use a proxy server that can’t be found.” when proxies are disabled.

Note that extra steps are required to use proxies with Tor Browser (see Whonix documentation if this relates to your issue).

1 Like