[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Tor Browser crashing in Whonix VirtualBox since upgrade to Host Linux Kernel version 5.10.0-15

just tested this now and not reproducible on my end using whonix 16.0.5 (latest image) with vbox 16.1.34 (latest version) in debian host.

@midge @crash139

Can you test this with latest whonix version available? (you can download and import while you have the old whonix images no issues)

If the newest whonix working then backup your old files in your old whonix and restore them in the newest whonix, if not working report back here.

1 Like

Hello TNT_BOM_BOM,

As I mentioned in my earlier posts, I have test all possible combinations including downloading and installing or re-installing, virtualbox, Whonix and TOR-browser. All give me the same issue in Whonix.
I have no issue with TOR-browser on the same workstation outside of Whonix.
Somehow the issue is graphic orientated.
I am running the above on the latest Debian, I have two different monitors running in 4K. That may be the problem, perhaps.
It is totally unusable now as it crash within 30 seconds of loading and does create strange transient artefacts in the TOR-browser window that are very noticeable if I move the mouse cursor.
Thanks for your interest in this.

Problem is most likely the latest kernel version 5.10.0-15, it ruined all my VMs very badly…, just downgrade kernel on your host and try if this fixes your problem.

2 Likes

Here is more info running from the xfce terminal:

msgdispatcher script bug.

No panic. Nothing is broken. Just some rare condition has been hit.
Try again later. There is likely a solution for this problem.
Please see Whonix News, Whonix Blog and Whonix User Help Forum.
Please report this bug!

who_ami: ‘user’
msgdisptacher_username: ‘’
msgdispatcher_identifier: ‘’
msgdispatcher_appendix: ‘’
delete_wrapper: ‘/usr/libexec/msgcollector/msgdispatcher_delete_wrapper’
msgdispatcher_sudo_wrapper_command: ‘’
output_msgdispatcher_sudo_wrapper: ‘’

error_text: ‘exit_code: 0 | text: Failed to set up inotifywait! inotifywait_folder: /run/msgcollector | wait_exit_code: 141’
last_exit_code: ‘0’

Hope this helps and thanks again for all trying to help.

@anonimac
Hi there anonimac,

I think you are on the right track.
The little research I have done seems to indicate that too. The issue is between virtualbox and the kernel version 5.10.0-15.
I will not be able to check for sure until tomorrow (restarting my workstation is a huge job) when I will report the results here.
Thanks for that insight.

1 Like

I am very sure the problem will be fixed after you downgrade the kernel on your debian host from 5.15 to 5.14. This version gave me tons of problems, didnt know what to do for days and had to reinstall all my VMs from the stratch.

I had segmentation fault errors in almost every app, broken update and upgrade(bizzare errors i have never seen before like “Hash Sum Mismatch” after apt update) , SIGSEGV errors in all chromium based browser, broken TOR, sdwdate and swap file creator on Gateway, all messengers broken/crashed and tons of other problems and errors. Now everything works good after kernel downgrade.

Dont reinstall your Workstation, first try to downgrade and check if problems on your WS are fixed.

1 Like

@anonimac

Thanks anonimac. Rebooting my workstation with the previous kernel (5.14 instead of 5.15) did indeed fix the problem occurring. No need to make any changes to any VM or whatever. Just boot the workstation with the previous kernel.

Still don’t know what the problem is, but at least I have a working whonix until the issue does get resolved by virtualbox, linux kernel or whatever. :slight_smile:

Thanks again to all who tried to help.

Does that kernel version cause any issues on the host operating system? (Outside of any VMs.)

Was both, host kernel and VM kernel updated?

Most likely related to kernel version.

That code msgcollector/msgdispatcher at master · Kicksecure/msgcollector · GitHub is pretty old (but that doesn’t imply “bad”, it’s functional and no updates required) and unchanged in a long time.

@anonimac Awesome! Nice discovery

Checked this in Debian bookworm 11 which is currently using kernel 5.17 and it doesnt has this issue.

So user can either downgrade or upgrade from 5.10.0-15 until a fix is pushed.

(Though user can as well switch to KVM if he want to stay on 5.10.0-15, there is no reports that this is produced inside it)

I had some of these isues when I updated to wayland and installed the hardened kernel, the xwayland server where flickering and I was having crashes in whonix.
Are you running Xorg?
Are you running the hardened kernel?

  • Using debian with xfce, so thats an xorg.
  • Using debian default kernel, so thats not a hardened by default.

But im not aware of any hypervisor fully/natively working on wayland (without xwayland).

Kernel 5.15 does not cause any problems on the host but only on all VBox VMs. I tried to install kernel 5.15 on my VMs and so far as i can see it did not do any harm.

@Patrick
Only had to change the booting of workstation to the older 5.14. No change required to VirtualBox or the VM.

1 Like

@redex
Yes, running Xorg and no, not hardened kernel.

Thank you so much for solving my problem! I tried it just now and it worked.

Well, I have tried on the host machine 3 different kernels with no luck:

  1. linux510 5.10.126-1
  2. linux515 5.15.50-1
  3. linux517 5.17.15-1

I have up-to-date Manjaro 21.3.2, latest VirtualBox 6.1.34 and latest Whonix 16.0.5.3. Do you have any tips?

cant reproduce here on debian, but as a side request can you try Whonix

  • KVM and see if it has any errors?

skincare3201 via Whonix Forum:

(Whonix is based on Kicksecure.)

Found these posts as I had same reported Tor browser crashing (and noise/artifacts prior to crashes) the other day in Virtualbox on updated to current Pop!_OS 22.04 LTS; this morning I set up qemu using Whonix for KVM on same device and said OS; all issues gone, Whonix and Tor browser acting as they should (tested through using for browsing over four hours, no problems). Hope this is useful.

1 Like

OK, Debian had a new kernel update from 5.10.0-15-amd64 to 5.10.0-16-amd64.

With the new kernel the issue still exists: Tor browser crashing and noise/artifacts prior to crashes.

Still no issues with kernel 5.10.0-14-amd64. Issue only exists with 5.10.0-15 and 5.10.0-16.

Still don’t know if the issue is caused by TOR browser, Whonix, Debian kernel or VirtualBox! I really have not got the machinery or time to test all combinations. I am starting to think that I may switch host distribution (but that is a major undertaking and I would like a guarantee that it works under the new distro before doing so).

The error is as follows:

Fontconfig warning: “/home/user/.tb/tor-browser/Browser/TorBrowser/Data/fontconfig/fonts.conf”, line 85: unknown element “blank”

###!!! [Parent][MessageChannel] Error: (msgtype=0x390142,name=PContent::Msg_CommitBrowsingContextTransaction) Channel error: cannot send/recv

Fontconfig warning: “/home/user/.tb/tor-browser/Browser/TorBrowser/Data/fontconfig/fonts.conf”, line 85: unknown element “blank”
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
/home/user/.tb/tor-browser/Browser/start-tor-browser: line 362: 3883 Segmentation fault (core dumped) TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox --class “Tor Browser” -profile TorBrowser/Data/Browser/profile.default “${@}” < /dev/null
[ERROR] [torbrowser] Tor Browser ended with non-zero (error) exit code!

Tor Browser was started with:
/home/user/.tb/tor-browser/Browser/start-tor-browser --verbose --allow-remote .

Tor Browser exited with code: 139

Hope this helps someone! :slight_smile:

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]