Tor Browser 8.5 in Whonix no longer can save passwords (and it deleted all existing ones)

Not sure if this is a Whonix specific issue, or an upstream Tor Browser issue!

I updated to 8.5 in my Whonix (from inside the TB Firefox), and now my previously-saved passwords have disappeared, and also password saving doesn’t work.

Anyone else experiencing the same?

1 Like

we never managed making Tor Browser save passwords anyhow.

For saving passwords, this has always worked for me for torbrowser 8.0 and 8.5 in appvms like anon-whonix:

  1. Uncheck “Always use private browsing mode”
  2. Restart torbrowser
  3. Check “Remember logins and passwords for websites”

Torbrowser will now always offer to remember passwords (and does!)

1 Like

Mine has worked since Whonix v13 (and probably earlier IIRC) if I simply do the steps @tatertot mentions above. It seems pretty standard for the Tor Browser here.

Only now with this update to 8.5 has it suddenly failed, and much worse, deleted my entire existing password store. (It’s a good thing I do backups.)

Anyway, turns out it is an upstream tor browser bug, now acknowledged and with a simple fix to restore passwords back easily.


So, problem solved solvable.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]