Tor Browser 10 without Tor

Hello. I’am using TOR Browser without tor on my whonix windows wm.
And today after update it is dont work. No connection.
iam using this method wiki/Other_Operating_Systems#cite_note-5


Please tell me what i can do. 9 version work perfect.

I came in here for exactly the same thing. Ive been lurking for a few months since first trying Whonix.

For my non-torified I have been using both of these set to False;
network.proxy.socks_remote_dns / extensions.torlauncher.start_tor.

I launch the terminal window from the folder or desktop where non-Tor browser start link / folder are held and paste;

env TOR_SKIP_LAUNCH=1 TOR_TRANSPROXY=1 ./start-tor-browser.desktop

Browser opens with the red screen.

Since the V 10 upgrade today it no longer connects after opening. I have gone thru the about:config and can’t tell why. I see minor changes to; “” / network.http.altsvc.proxy_checks – I tried adjusting these and didn’t seem to make a difference.

I have made several attempts to download tb-starter / secbrowser based on instructions here but am always met with error messages so not sure if it’s not being updated I am not tech savy enough to understand what’s going on with that.

Hopefully someone knows of a fix to get V 10 up and running.

Whonix does not produce Tor Browser. The Tor Project does. And Whonix did not make any changes related to that.

Therefore to have a chance of seeing this fixed, this issue must be reproduced outside of Whonix. Meaning, without Whonix involved. A Debian busted based VM would be good. And then the issue needs to be reported on the Tor Project issue tracker.

As per Free Support for Whonix ™.

“Whonix does not produce Tor Browser. The Tor Project does. And Whonix did not make any changes related to that.”

Is the SecBrowser a Whonix product?

Non-Affiliation with The Tor Project

SecBrowser ™ is a derivative of Tor® Browser, produced independently from the Tor® anonymity software and carries no guarantee from The Tor® Project [archive] about quality, suitability or anything else.

SecBrowser ™ can be installed using tb-updater [archive] which is a package developed and maintained by Whonix developers.

Are the adjustment noted above the equivalent of the SecBrower?

How does SecBrowser ™ disable Tor?

SecBrowser ™ supports custom user preferences “user_pref” which can be used to change browser configuration and behavior. In tb-starter the user preferences that disable Tor are located in /usr/share/secbrowser/user.js .[20][21] When SecBrowser ™ starts this file is copied over to the corresponding SecBrowser ™ profile where the custom user_pref(s) are parsed.[22]

Tor is disabled by setting the following three preferences to false.

user_pref(“extensions.torbutton.startup”, false);
user_pref(“extensions.torlauncher.start_tor”, false);
user_pref(“network.proxy.socks_remote_dns”, false);

Has SecBrowser stopped working with No-Tor Whonix created Tor browser V 10?

Edit by Patrick:
update onebox

SecBrowser 10.5a1 also broken. If you want to see this fixed, see my previous post.

Tor Browser 10 without Tor - #3 by Patrick

I assumed it was also broke and was looking to see if whonix was able to do a work-around yet so those of us with the diy sec browser can make the changes. I have never been able to load sec browser or tb-installer on my machines always broken messages of some sort.

Mozilla networking preferences

Customizing Firefox Using AutoConfig

Customizing Firefox Using AutoConfig | Firefox for Enterprise Help

The 2 resources above allow an enduser to work with what the Tor project have done in its continual efforts to create a product liken to what the minions of Alphabet Inc :smirk_cat: envision a browser – minimalist tweakable options/features in the name of “ease” of use for ‘non-power’ users.
:100: :sparkling_heart: Seriously…

Manually create 2 files as follow -

Create a file firefox.cfg with the 4 lines below.
Place it within the directory alongside the files
firefox.real and firefox

In Linux, that would be inside browser_en-US/Browser

lockPref(“extensions.torlauncher.start_tor”, false);
lockPref(“network.dns.disabled”, false);
lockPref(“network.proxy.socks_remote_dns”, false);
lockPref(“network.proxy.type”, 0);

The second file will be autoconfig.js

Using a simple ascii editor, enter these 2 lines -

pref(“general.config.filename”, “firefox.cfg”);
pref(“general.config.obscure_value”, 0);

Save it with the js extension for it to be recognised as a javascript file.

Place this file inside the pref directory -
In the Linux Tbb package, it is


You will notice a pre-existing file named channel-prefs.js in this same directory.

I had mentioned the pre-existing files to help anyone who is using an OS other than Linux to navigate to the appropriate directory / folder.

Cheerios :smiling_face_with_three_hearts:


Did you test this with Tor Browser 10?

I raised this issue at the tor browser gitlab project (I can’t post a link - nice one whonix).

It seems that the preference that allows firefox to send DNS requests out was changed in tor 10 and the code that deals with TOR_TRANSPROXY wasn’t modified (i.e. the left hand does know what the right hand is doing).

So you should get 10 to work by going in to about:config, type in network.dns.disabled and set it to false.

I’m am not yet sure if this will be addressed by tor so that you don’t have to manually set this value in future.


Indeed, It works with version 10 -

  • tor-browser-linux64-10.0_en-US.tar.xz
  • tor-browser-linux64-10.5a1_en-US.tar.xz

In zwei Worten… Ja, Sir :sunglasses:
3 of my relatives confirmed success on Windoze hobbled machines.

All users in the family gave their thumbs-UP :smiley: :heavy_check_mark: when used on Qubes: Debian appvm, and various other Linux distributions.

1 Like

You can post links now.

In SecBrowser…

This did not work for me:

user_pref("network.dns.disabled", false);

This did work for me:

user_pref("network.dns.disabled", true);

Tor Browser 10 without Tor…

Could someone please update the related documentation chapters



10.0 true: broken
10.5a1 true: broken

10.0 false: functional
10.5a1 false: functional

1 Like

1 Like

Tor Gitlab ticket

1 Like

Yes False worked for me also v10 all I needed to do was add the - network.dns.disabled. Thanks to those that solved this.

1 Like