Whonix Wiki Download Docs News Support Tips Issues Contribute DONATE

Tor Bootstrap test keeps failing

Hello all, I am running whonix through virtual box on an ubuntu hosted laptop. Lately, almost every time I run whonix I get a tor bootstrap error. When I restart the system it usually fixes it, until it comes back… I have no idea what the issue is, can somebody please offer some advice? everything is up to date too, I’ve done apt-get upgrade on my host, whonix gateway and workstation. thanks

Hi whonixhelp1

You get a bootstrap error every time you start Whonix?

How long does it take before you have a bootstrap error again? 10 min, 1 hour…?

Does your computer keep time properly? Can you run date in the terminal and make sure its the correct UTC time. You can compare your result to the current UTC time on this site:


If your are using snapshots are your reverting to the same one when you restart?

Can you run whonixcheck in Whonix-gateway konsole now and also when you have the bootstrap error and post the result here.

Hi there, thanks for the response. Lately yes the bootstrap error comes up eventually almost everytime I run whonix. It usually doesn’t happen until after maybe an hour or longer of running it though. I do sometimes get time sync errors too and as far as I know, my workstation and gateway are both set to UTC (through the virtual box settings). I get the bootstrap timeout error too when I run whonix check on the gateway as well

Hi whonixhelp1

It just occurred to me that I responded to your thread Whonix time synchronization consistently fails.As you mentioned in that thread, this can cause networking problems. I would focus on the time sync issue as that will most likely resolve your bootstrapping issue.

Oh wow, could you remind me what I may need to do to fix the time sync? That doesn’t happen as often as the bootstrap error though.

Hi whonixhelp1

I should rephrase; what is causing your time sync error and loss of connectivity (as you stated in your other thread ) is most likely what is causing your bootstrap error.

  1. Did you make any changes to Whonix-gateway that could have caused this?
  2. Is there anything in your logs that stands out?
  3. Can you run whonixcheck while your system connectivity is OK and post any errors.
1 Like