[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

timesync has gone missing with no explanation?

The Whonix Gateway had a program called ‘timesync’ that was recommended by Whonix to be run every time the computer started. After installing some recent updates on v12 of the Gateway the program went missing, and I would get Red Font Errors when running ‘whonixcheck’ as well. This caused me to re-install the Gateway from a fresh download (v13), but even this copy of the Gateway still does not have timesync. Timesync was 1 of 2 very important programs on the Gateway (whonixcheck being the other), and it is gone with absolutely no explanation or mention anywhere on the internet. This website, these forums, the wiki, IRC, Reddit, Google, not one mention of ‘timesync’ at all.

‘timesync’ also used to appear in the ‘whonix | more’ command, but it’s not listed there anymore either!

So what happened to timesync and how do I get timesync back installed on my Gateway so it’s safe to use Tor again…

Was replaced by sdwdate-gui.

I run the Gateway with 256MB RAM so I don’t have/use the GUI! What is the linux version of the new ‘timesync’ now? Or is there now just the GUI version??

And what is the reason why a critical security feature was removed silently with no explanation given? It was also removed from the standard Whonix help file as well!

Linux version… I guess you mean cli version. (There never was a
non-Linux version.)

timesync was just a gui for sdwdate. The actual time synchronization
daemon is sdwdate which works fine in cli. (sudo service sdwdate status, tail -f /var/log/sdwdate.log, etc.)

There is no replacement for timesync cli.

Timesync was replaced by sdwdate-gui, because it’s the next step in the
evolution of usability. It’s a popup free solution. It’s a rewrite in
python. Shorter, cleaner code. More bug free.

There are no resources / no maintainer to provide background
notifications in cli. That was harder than anticipated and the focus is
much less on cli but rather on anonymity/security/privacy/usability not
so much geek stuff.

Ahh for starters yes I meant cli and not linux! Silly mistake! Anyway, I run the 256MB version of the Whonix Gateway which just boots up into cli. Before, the instructions for this method were to run ‘timesync’ and then ‘whonixcheck’. If needed, also apt-get to do updates. So when you say the old ‘timesync’ was just a GUI for something else, how could that be when it was a cli program? I would type ‘timesync’ as root, it would display some console output for about 5-10 seconds, and then return to the command line. How do I do this again now?

timesync was also a “cli gui”. A command line based user interface to sdwdate.[quote=“jessica1991, post:5, topic:2580”]
How do I do this again now?
[/quote]
sdwdate is a usual linux daemon.

sudo service sdwdate status
sudo service sdwdate restart
tail -f /var/log/sdwdate.log
etc.

So if I understand you correctly, the time is now synchronized automatically by a system service?

PS: I just want to thank you for taking the time to help me out.

So if I understand you correctly, the time is now synchronized automatically by a system service?

Always has been.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]