timesync Error: vgsvcTimeSyncWorker: VbglR3GetHostTime failed

I just installed from Whonix-CLI-
I get spam on the current tty, 20 times after boot:
timesync Error: vgsvcTimeSyncWorker: VbglR3GetHostTime failed; rc2=VERR_NOT_SUPPORTED
I’m using VirtualBox 5.2.32 is that a problem?
It seems to know what time it is even without a network connection. So I’m not sure what it means but if it’s not supported the first time it probably won’t be supported the next 19 times

I’m using VirtualBox because that’s what the download page points to but I’m thinking of switching to KVM.

Capture3 hosted at ImgBB — ImgBB

This can be safely ignored.
What’s happening is that virtualbox-guest-utils is asking VirtualBox for the time. Which is blocked as per Whonix default VirtualBox VM settings.
Previously this was disabled inside the VM too through pacakge https://github.com/Whonix/vbox-disable-timesync but this was recently disabled since it causes more issues than it does good. This error message we have to live with but it doesn’t break anything.

2 posts were split to a new topic: Whonixcheck no longer Writing to tty1

I also get this. Thanks for informing it is safe.

However, how can it be suppressed? It spams my terminal prompt and I sometimes use it.

I guess this.

Try this.

sudo str_replace "start-stop-daemon --start --quiet --oknodo --exec /usr/sbin/VBoxService" "start-stop-daemon --start --quiet --oknodo --exec /usr/sbin/VBoxService -- --disable-timesync" "/etc/init.d/virtualbox-guest-utils"

Did that work?



does not work since these are dmesg.

After login into a virtual console the following could be tried:

sudo dmesg --console-off

That would hide all kernel messages from that virtual console.

Are there any ways to filter messages sent to dmesg or to block certain applications from writing to dmesg? I haven’t found any.

These messages only appear on tty1 (virtual console). Not on tty2. So just use tty2 rather than tty1. Refer to Platform-specific Desktop Tips on how to do that. Use F2 rather than F1.