[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Testers-wanted! Whonix 8 Release candidate #1 Whonix 7.7.8.6


#21

[quote=“Occq, post:16, topic:67”]~Cerberus.

Can you run the script again, appending a log?

sudo ./whonix_build --tor-gateway --bare-metal --build >> /home/user/log-gateway 2>> /home/user/log-gateway

Looking at my previous logs, 2200 does a lot of things so it’s hard to pinpoint without the actual log.[/quote]
lol, we’re beating each other typing. now, my problem here is that i’m building this beast on a cli-only machine that is supposed to be the physically isolated gateway. thus, it’s not too easy to append logs other than typing them by hand. that said, i’m going to run the build again on tty2 and have a look at it utilizing “less”, then I come back to you. again, this happens with 7.7.8.7, not 7.7.8.6.


#22

~Cerberus.

This is just a line that I got off my 2200 log. Sorry for the confusion.

I don’t have any good answers.

  1. Try building Whonix with a log over half-baked Whonix. Might work, might not.

  2. Delete and start fresh with a log.

  3. Post the 2200 section of the log (if the error will persist)

Even if you are doing CLI you can still redirect all the output to a file/log however I’m not sure if you can get the file out then. USB? Or, a lot of work, installing light DE (apt-get install xorg iceweasel lxde-core no-install-recommends) and uploading it there.

But then you have to delete everything again.

Alternatively, just for troubleshooting, you can build with the --tor-gateway --bare-metal log option in a VM. It’s not the same situation but the error should be if it’s due to your modifications. If not, one less variable to worry about.

Best of luck.

LOL @ adrelanos’s edit answer :smiley:
#17


#23

sure, I’m going to start from scratch. the big pain here is the encrypted storage format. anyways, i just run it again and it complains about two things:

/usr/share/whonix/postinst.d/70_locale detected!
/var/lib/dpkg/info/whonix-gateway-files.postinst detected!

then:

dpkg: error processing whonix-gateway-files (–configure) …

then:

build-steps.d/1100_prepare-build-machine

seems to be something else then before. not sure what to do now. seems to be completely messed up.


#24
Alternatively, just for troubleshooting, you can build with the --tor-gateway --bare-metal log option in a VM. It's not the same situation but the error should be if it's due to your modifications. If not, one less variable to worry about.
I haven't actually modified anything other than building terminal-only, no-report, apt-repo on - closely following the docs.
LOL @ adrelanos's edit answer
I second that!

#25

You probably need to delete all traces of the previous installation then.

Not many people test those options so there might be an error in the docs/design itself. I err on the side of caution.


#26

Sorry about that edit. Perhaps that’s why it’s generally not recommend to work as root. :wink: I hope I haven’t deleted a lot.


#27

[quote=“Occq, post:25, topic:67”]You probably need to delete all traces of the previous installation then.

Not many people test those options so there might be an error in the docs/design itself. I err on the side of caution.[/quote]
I’m already re-installing, without any crypto this time. Just to reproduce the actual error. Once I have something, I’ll get back to you!

Thanks!


#28

Pardon?

EDIT: oh I see. feel free to edit my posts to your liking :wink:


#29
/usr/share/whonix/postinst.d/70_locale detected! /var/lib/dpkg/info/whonix-gateway-files.postinst detected!
Generally, this isn't enough to trace the bug. I need to see which exact command failed and with which message. In this specific case, I think I can figure out anyway.

Fortunately, the /usr/share/whonix/postinst.d/70_locale script is standalone and idempotent.

Please run it.

I guess you don’t have update-locale installed? (Check with “sudo update-locale”.) You’re most likely missing the locales package.

Most likely you didn’t apply this step:


#30
Generally, this isn't enough to trace the bug. I need to see which exact command failed and with which message. In this specific case, I think I can figure out anyway.
adrelanos, we messed up here. the last error I posted was distinct to the actual/original building error, #11. I rebooted in the meantime and tried running the build process again and it came up with a completely other failure. Relevant is that it has been failing at 2000_install-files-packages step. also, it's too late ... the machine is gone already. i'm now starting from scratch and i'm going to post the 2000_install-files-packages error another time once i get there.
I guess you don't have update-locale installed? (Check with "sudo update-locale".) You're most likely missing the locales package.
sorry to say but this isn't the case. "locales" was definitely installed along with all the other requirements. Will get back to you asap (Debian is currently installing).

Also, did you notice, with all these recent posts, that you have a regular expression error in your instructions? #9


#31

I still haven’t catched up with everything raised here. Amazing activity.

Occq, thank you for the signing key related changes. I updated my signing key on whonix.org. And deprecated the “download from multiple sources” thing. Was a flawed concept. (Could be discussed in other thread, if needed.)

Occq, I confirmed your edits to the Debian and Physical Isolation page and added a notice on top, that it’s the testers-only version and that there currently is no stable version of it. That should do for the transition period. Hopefully Cerberus can make use of the less confusing version.


#32

[quote=“Cerberus, post:10, topic:67”]Comment on https://www.whonix.org/wiki/Physical_Isolation#Network_Verification

grep -r eth0* * grep -r eth1* *
Wrong regular expression. Throws lots of irrelevant configuration files.

Should instead read

grep -r eth0 * grep -r eth1 *[/quote]
Fixed.


#33

This one only gets used when manually started. No need to change.

I do need to change these due to specific network configuration.
What you could also *try* is not change anything and change these files after whonix's build script finished. Could work. Could be simpler than learning git just for this.

#34

I guess I now answered everything. With all the recent posts, I hope I didn’t miss something. Please restate, if that is the case.


#35
I guess I now answered everything. With all the recent posts, I hope I didn't miss something. Please restate, if that is the case.
Yes, thanks! Btw, I'm almost there with the second try. Should be at maximum half an hour to get the logfile posted.

EDIT: and there you have it. same build error again - with 7.7.8.9 this time. I’m going to re-run quickly, save the log and post it for you.

EDIT2: AAAAAAAArrrrrrrrggggggggh!!! can’t believe it. Re-running it produces the same useless distinct error again (not the actual building error - the build is still failing at 2000_install-files-packages, the very same thing).

So now, how do I scrollback in tty? I’m not going to do this another time :wink:

EDIT3: Shift+PageUp doesn’t work and it’s at best 50 lines above the log part I can see on the screen. I leave the rig running and hope for an idea to scroll up. Problem is, re-running it produces a completely distinct useless error. What’s absolutely clear at this point: It’s broken! I followed the physical isolation manual to the letter. terminal-only, no-report, apt-repo on - everything else on default. Fails at 2000_install-files-packages step.


#36

Cerberus’ summary/interim result:

To briefly recap my testing results (level-headed) …

a) built 7.7.8.7 + 7.7.8.9 (whonix-gateway, bare-metal on bare metal) on Debian 7.4.0

b) introduced:

/etc/whonix_buildconfig.d/50_terminal_only
/etc/whonix_buildconfig.d/50_whonix_apt_repository
/etc/whonix_buildconfig.d/50_no_report

-> followed https://www.whonix.org/wiki/Physical_Isolation#Build_Configuration_.28Optional.29 to the letter here.

c) modified:

whonix_gateway/etc/network/interfaces.whonix
whonix_gateway/usr/bin/leaktest
whonix_gateway/usr/bin/whonix_firewall

-> replacing eth0 > wlan0, eth1 > eth0, committed changes

d) everything else on default

Remark: I typed everything by hand (b+c) twice, so I highly doubt that it’s actually typos (no copy & paste). I followed the manual very carefully (twice), certainly installing all requirements, i.e. grml_packages.

Result: both builds failed (reproducible) at 2000_install-files-packages step, actually pretty soon after “debsums something”(while this went through). then it went pretty fast > error! silly tty doesn’t let me scroll back and re-running the build process produces some totally distinct error -> thus I’m not able to post a log - it’s basically a one-time error > re-install loop. Went through this twice. Hope you can reproduce. I’m basically cooling my head now. A bit pissed off after throwing 14+ hrs out the window including Debian installs. Hope you don’t mind. I’m now waiting for your feedback, I hope we find the actual issue together and then: new try, (hopefully) new luck - with at least one (then understood) issue out of the way!


#37

Without seeing the command which failed and with which error message, I have no idea how to fix it or how to advise a workaround.

Please redirect the output to a log.

I think for Whonix 8 + 1, I’ll revise the error handling. Stop after the actual error to make it better readable and ask to press enter before exiting.


#38

~Cerberus.

I’m sorry you are still having problems. Having ran a few dozens failed builds I understand the frustration, especially the c&p inconvenience.

I agree with adrelanos that log is needed here. Set the command, wait for the fail, open with nano and look for the section in red. Scroll up a bit for the first time the word “error” or “failed” appears and type that here.

I ran the 7787 bare metal in a VM and it works. My suggestion would be to either run a vanilla, non-modified, version on bare hardware or run the modified version in a VM. Both with log.

~adrelanos.

Have you figured out a way to have both log and screen output? My tee adventurous failed miserably. Whatever I tried it never registered if I broke the script with Control-C.


#39

I found out how to make a copy of file descriptor 1 (stdout) and 2 (stderr) and how to redirect those copies to a file. Part of it has been sorted out.

You could run the following manually before building.

That should redirect everything to ~/logfile and still show usual output in terminal. Does this work for you?

The issue with automating log creation I am thinking about is where to store the log. Ideally, logging would begin as early as possible. Probably not before setting up the error handler trap. Ideally in the help-steps/pre script. Getting the variable which points to the whonix_binary folder doesn’t happen before the help-steps/variables script. Also figuring out vmname and version doesn’t happen before the help-steps/variables script.

I have some code on my hdd to log to environment variable “log”. It could be set using “export log=~/logfile” and used by appending “-E” (which means, preserve environment variables) to “sudo”, i.e. “sudo -E ./whonix_build --tor-gateway --build”. Would that help?

What in case environment variable “log” isn’t set? Should it default to ~/whonix_build_log? “~” could result in /root/whonix_build_log, when the build script has been started as root and to /home/user/whonix_build_log if the build script is run as user using sudo. Not sure how confusing that would be.

Or in case the case the environment variable “log” isn’t set, I could default to /var/log/whonix_build_log. Who would look in that folder? Also access rights for the log file are again troubling me. I guess it would be acceptable to set the log to “read/write anyone”? I don’t like to see the build script failing, because some step which can be run without root can not continue to write the log file, which has been created as root user.


#40

Build on tty1 with

View the log on tty2 (in realtime) with

That’s what I currently do to reproduce the error for the third time.