sys-whonix onionized dom0 update fail on Qubes R4.1 with Qubes-Whonix 17

after upgrading to the latest whonix-gw with studio
sudo release-upgrage, I cant update my system (dom0) anymore, I’m getting an error, Cannot retrieve repository metadata (repomd.xml) status code 404 , I use onionized repo for dom0. I tried to use normal repo it didn’t work, I also changed net vm of updates and that worked so In quite sure it is sys-whonix related.

The only command that works is pseudo cubes - dom o - update - - releasever=4.1

Is sys-whonix generally working? Run systemcheck.

1 Like

anon-whonix working?

Normal connection needs to be verified first before looking into dom0.

1 Like

Yes, anon-whonix and sys whonix is working it’s just when you use the global update gui, it fails to update.

It’s It says failed to upload metadata repo qubes domo current and it spits out the onion link for the repo and a failed 404 code

5 posts were split to a new topic: sys-whonix dom0 updates failing on Qubes-Whonix 16

Whonix 17 wasn’t released for Qubes R4.1 and won’t be.

If you like to use Whonix 17, you need Qubes R4.2.


1 Like

Can you upgrade Whonix Templates?

Can you upgrade other Templates over sys-whonix?

For debugging purposes, please run:

systemcheck --ip-test


  • anon-whonix
  • sys-whonix
  • Whonix-Gateway Template
  • Whonix-Workstation Template

And post the output here in case there are any warnings or errors. Otherwise please confirm if no warnings or errors are shown.

Please also provide the following log:

In sys-whonix

sudo journalctl --boot --no-pager -u qubes-updates-proxy.service

Is this issue still reproducible?