Starting XCFE Virtualbox give Guru Meditation


I have the following setup
Dell Precision 7520 With Windows 10 Version 2004 (OS build 19041.508)
Virtualbox 6.1.14r140239

I downloaded the Whonix XFCE ova file. I checked the sha512 and the gpg signature, all shows as good.
I imported the ova into Virtualbox, but when I start the gateway I get a “A critical error has occurred while running the virtual machine.” (see image below)

I proceeded to download the Whonix CLI ova and imported that. Both CLI VM’s startup with no problems and whonixcheck show all is good.

I then tried the start the XFCE-workstation with the CLI-Gateway, but the XFCE-workstation box also gets the error screen.
It basically boots, shows the grub screen, then proceed into the OS up to the second line " initiating ramdrive", after this the screen blanks for up to 1 minute and then Virtualbox presents the image below.

screenshot not excepted in forum post

I’ve tried all the options on the “black-screen” issue page with no success.
Rebooted my laptop with nothing but Virtualbox started, no success.

Is this a known issue? how can I resolve it? I can provide the log files, if there is a way to upload it.

Is this your first time running virtual box on your machine?

You may have to go in to BIOS and allow the use of virtualization.

See General VirtualBox Troubleshooting Steps. Another reply maybe soon.

Hi @humanDecoded,

No I’m using Virtualbox for 3 plus years on this laptop. I’m a Virtualization Administrator for almost 20 years. It’s not the hardware setup, I’m sure for that.

Hi @Patrick,

Just for interest sake I did go through the Troubleshooting steps (just to make sure I didn’t miss anything) but no… no luck.

Perhaps a low RAM issue? Try:

Upgraded your account so you can post links now.

Added a new documentation chapter just now, please have a look:
Guru Mediation


SO interesting article I came across solved the problem and hopefully it can help someone else in the future as well.

Full disclosure, I have both VMware workstation and Virtualbox installed. This worked perfectly side by side for year, although I haven’t used Virtualbox in the last few moths only VMware Workstation.

When upgrading to Workstation 16, I was confronted by a new security feature that had two options (can’t remember then both) but one was to enable the hyper-V subsystem which now can run side by side with VMware workstation. This I chose (almost blindly) and continued to work in my Vm’s.

After running line for line through the log, I came across Virtualbox stating that there are no VT-x available. With some searching a person stated that hyper-V holds on to the VT features, VMware now knows how to interact with Hyper-V to get access to the VT features, but Virtualbox doesn’t. Thus to Virtualbox it seems as if the laptop doesn’t have any VT features. I ran a

bcdedit /set hypervisorlaunchtype off

and rebooted.
Problem solved, the XCFE Virtualbox starts with no issues.
Thx for the help and understanding.
Whonix looks like a great product

1 Like

Thanks for the report!

Added to documentation:
VirtualBox/Troubleshooting: Difference between revisions - Whonix

Might be worth pointing out you’re meaning VMware Workstation 16. Otherwise easily confused with the upcoming Whonix 16 / Whonix-Workstation 16.