[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Sound settings/volume in Whonix not used/acknowledged on KVM?

I am running Whonix 11 under KVM (on Linux Mint) but I don’t think this issue is specific to either the virtualizer or the host. Feel free to move it if it is.

I notice that any changes I make to sound settings within Workstation itself, for example to mute all sound output completely, is not respected within Workstation, and any sounds that are played (system, music, video files, internet etc) are still at full volume just the same.

If I mute sound using the host system settings (Mint) then it works, but no changes seem to be feasible under Workstation as a guest whatsoever. Is there an extra step needed in order to give audio control within the guest to itself?

Edit by Patrick: added KVM to subject.

Good day,

depending on which settings you use, it may be the case that you may only change sound settings from within the host. This has (in the case of KVM) to do with things like Sound Passthrough and other more specific settings. Depending on which Soundcard you use for example, it may not be supported completely driver wise which is why KVM doesn’t give you the option to modify the sound levels from within a session. Furthermore, if you really only want to get sound from your host, but not from your Whonix-Machine, you may set this by going (on Linux Mint) into Settings, Sound, Applications and turn off the sound there.

Have a nice day,

Ego

Thanks… the problem is that I actually want/need to be able to toggle the sound volume higher or lower on the fly, at will, within Whonix Workstation whenever I want to. If a specific source is too loud or too quiet by default, I need to be able to use a volume slider to adjust it as I see fit, at any time randomly. Then a few seconds later change it upward or downward again.

Since I run Workstation in full screen mode, having to navigate back out to the host system, change the volume, then back into Whonix again, and then repeat again 20 seconds later, each time I want to change the volume, is not ideal.

It isn’t a question of just wanting to select one permanent fixed volume level, and leave it there. It needs to be changeable in a fluid way at all times.

This has always worked for me on VirtualBox.
On Qubes-Whonix, the dom0 sound settings work for me. Also apply for Qubes-Whonix-Workstation.
Hence, I think this is KVM specific. Therefore moved to KVM forum.

I guess for information collection it might help to try reproduce this on plain Debian KVM. Then compare with Whonix KVM. Then perhaps this can be broken down to a upstream KVM issue or feature request?

I find a decent number of things work a little bit better (or easier at least) under VirtualBox than under KVM. However I chose the latter option because the Whonix wiki recommends KVM as a more preferable option, due to trust licensing issues, libre aspect etc. Is this still the official position? That if one isn’t going all the way to Qubes-Whonix (for now) it is still better to use KVM over VirtualBox?

That is slightly different situation, since due to the way Qubes is set up, Dom0 is like changing master volume on the “host” system itself. Similar to changing volume in Linux Mint instead of on Workstation. But changing volume within Qubes-Whonix-Workstation would be comparable, yes… I don’t have it installed to test on my system, due to hardware issues, so cannot test.

I find a decent number of things work a little bit better (or easier at least) under VirtualBox than under KVM.
Indeed! (It starts with much more complicated setup instructions for import/setup that require cli and goes on to issues such as this.)
However I chose the latter option because the Whonix wiki recommends KVM as a more preferable option, due to trust licensing issues, libre aspect etc. Is this still the official position? That if one isn't going all the way to Qubes-Whonix (for now) it is still better to use KVM over VirtualBox?
Yes.

Each VM has its own volume slider in the host’s sound manager accessible from the taskbar icon. This is documented in the wiki context of muting a VM’s microphone.

[quote=“Patrick, post:7, topic:1476”]Indeed!
(It starts with much more complicated setup instructions for import/setup that require cli and goes on to issues such as this.)[/quote]

Very true… at first when I was installing Whonix over and over again many times (on different host systems, drives etc to test performance) I had to type those same console commands so frequently that I eventually put them all into several small executable bash/batch scripts, each to be run after the various different reboot points. Saved some time and hassle for sure.

Virtualbox is simpler, but I prefer to use the “better” system overall in terms of openness, freedom etc.

Accessible from the host system? Meaning in my case, Linux Mint? I’ve adjusted the sound in Mint several times using the systray icon in Cinnamon, but have never noticed separate sliders for each VM. I’ll take another look. But that means, if I have Workstation totally full-screen maximized so that it appears to be the only system visible on screen, and I want to change the volume, I have to always go back out to Mint, change the VM volume there, then re-fullscreen Workstation, each time? There is really no way to control volume locally within Workstation, ever?

So this turned out to be slightly a mistake on my part. By default KDE in Workstation doesn’t show any sound/volume icon in the system tray upon first install. I downloaded and added a third party “widget” for this panel (I forget the name… Aracos or something) and tried to use its volume slider to change the volume, without success. But when I accessed “KMix” the default volume controller in KDE, it did indeed correctly change the volume within Workstation as expected, and can be set to add its icon into systray as well. Currently I can’t get that function to auto-start with Workstation, since it complains some autostart.desktop file isn’t present, but I’ll have to try to solve that issue separately.

Volume control from individual apps in Workstation such as VLC Player also works successfully. I was just so accustomed to controlling audio universally from systray icon, that I assumed it was a system wide issue. My apologies for leaping to conclusions before testing thoroughly.

Unrelated, I looked but did not see any VM-specific volume sliders in the systray widget within Linux Mint, while both Gateway and Workstation were running under KVM. Maybe it is a mint-specific incompatibility - not sure.

Unrelated, I looked but did not see any VM-specific volume sliders in the systray widget within Linux Mint, while both Gateway and Workstation were running under KVM. Maybe it is a mint-specific incompatibility - not sure.

Perhaps. Try looking at host volume controls when you are playing something in the VM. If its still not showing that could be a difference between desktop environments.

Inside the workstation VM did you see volume control systray icon when running on VirtualBox? If not I’ll file a feature request to include it by default. Customizing KDE usually has quirks and development resources are limited so you may not get it any time soon.

kmix autostart is disabled in Whonix by default by package:

To restore it, you can try the following command.

[quote=“Patrick, post:13, topic:1476”]kmix autostart is disabled in Whonix by default by package:


To restore it, you can try the following command.

Is there any security/privacy/anonymity benefit to leaving Kmix autostart disabled?

No, the only rationale of the package is the one in the github repository description [and debian/control file].

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]