[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

[SOLVED] I can't get into my workstation!


#1

First of all let me say, I’m new to debian So I dont know much about it at all.

VLC media player wasn’t opening, so I uninstalled it with “sudo apt-get remove vlc”. It did get removed but I wanted to be sure ALL of it’s files were gone before reinstalling it. So I did “sudo apt-get remove --purge vlc”

After that, for some reason the dolphin file manager stopped working. When ever I tried to open a folder from my desktop, it would say, “open with…” and file manager was not an option.

I clicked on the KDE button down in the bottom left and tried opening file manager from there but there was no response.

When I shut down the workstation and rebooted it, It brought me to this screen:

I never had to login when starting up the workstation before, it would always open right up!
I have no clue what the host login is. I don’t remember ever setting that up. Is there a default login that I don’t know about?
Everything I try is incorrect.
Is there any way around this? Thanks for the help.

UPDATE

One of the logins I tried finally worked! But the workstation didnt open as normal. Why is this happening and how can I fix it?


[SOLVED] Can I backup my workstation data?
#2

Hi GuyInTheSky

You probably removed dependencies that KDE needs to function properly when you remove --purged vlc . If you reinstall those packages the issue you are having should clear up.

You can use a virtual console to install VLC. Just in case you didn’t already know you were logged into a virtual console ( tty1 ) in the last screen shot.

After you open and log into the virtual console run this command:

sudo apt-get install vlc

You may have to reboot Whonix for the changes to take affect.

Keep in mind that you should never remove packages unless you know it is safe to do so.


#3

Hey, thanks for the response. Unfortunately when I tried reinstalling vlc like you suggested, it did work. It said it was already at its newest version.


I mean look at all the packages that it says are no longer required! Even I can tell by looking at that something is wrong.

Is there another way to get lost packages back? Or a way to re-install all of whonix’s dependencies? Is it possible to get out of the virtual terminal and boot the workstation normally?

Thanks again.


#5

Try.

sudo apt-get install non-qubes-whonix-workstation

If it works, might be fixed after reboot.


#6

No surprise, https://www.whonix.org/wiki/Whonix_Debian_Packages says why.


#7

Patrick this worked. Thanks a lot for the help!