sdwdate problem

Sdwdate on Whonix Workstation does not work.

  • sdwdate - WARNING - Tor is not yet fully bootstrapped. Tor circuit: not established.

I mention that on Whonix Gateway works fine.
Can somebody confirm if this is a general issue? maybe is something wrong with my Workstation and is not a Whonix problem.

Thank you

Note: “a log entry is only valid at the time of the log entry.”

Probably shouldn’t be called “warning”, to be expected during boot.

Is this the last message ever from sdwdate in the log? If not, then it
can be safely ignored.

1 Like

I noticed the problem a few days ago. The log is not during boot, is after boot. Tried to restart sdwdate, reboot the Workstation, tried with another fresh Workstation, still same error: “Tor is not yet fully bootstrapped. Tor circuit: not established.”
Then maybe is something wrong with the Whonix Gateway. I don’t know how to troubleshoot the problem and I asked if somebody else have this problem. The clock seems to be synced, but again sdwdate shows that the circuit is not established.
It is the last log. Also the icon from sdwdate is with a orange circle and stays with orange forever.

What does whonixcheck say?

Not sure if this is related or not. Recently had an issue with sys-whonix throwing a similar time sync error and like the OP it it was not causing any connectivity issues. Wasn’t able to narrow down the problem but it was a new VM with every advanced config in the wiki so its hard to tell what caused the issue. Could have been a slow entry guard.

For more perspective, I created a sys-whonix VM that day for each torified client and only had that 1 sys-whonix throwing that error.

1 Like

[INFO] [whonixcheck] Tor Connection Result:

  • Connecting for 30 seconds.
  • Tor Circuit: not established.
  • Timesync status: not done.
  • sdwdate reports: Prerequisite check not done yet. More more information, see: sdwdate-gui -> right click -> Open sdwdate’s log
    ^Cwhonixcheck: signal SIGINT received. Cleaning up… Exiting…

This has to be sorted out first as per Tor Browser - New identity problem - #5 by Patrick.
Not an sdwdate issue for now.

It was a problem with Whonix Gateway, I dont know what, but a fresh Gateway solved the problem. Sorry if I wasted your time Patrick. Thank you


This breaks Whonix Gateway for not knowing when Whonix Workstation it is connected to tor.
Can you please take a look?

one='/usr/bin/onioncircuits {'

two='/usr/bin/onioncircuits flags=(attach_disconnected) {'

sudo sed -i "s#$one#$two#g" /etc/apparmor.d/usr.bin.onioncircuits

Did you try using onioncircuits in live mode? Otherwise live mode breaks onioncircuits is fully unrelated.

Was wrong what I wrote above. No one noticed it even though was fairly obviously wrong. Corrected in origin and in your post above.

Onioncircuits does not work in live mode. To make it work I used the 3 commands above. After using the 3 command above the problem described in this thread appeared.
Now I tried with a fresh Gateway entered the commands and the problem did NOT appeared. In conclusion, I can’t figure out what caused it, but now is working.

Whonix 15 KVM

I will keep an eye to see if this appears again. The Gateway was with no modifications prior to 3 commands to make onioncircuits work on live mode, thats why I thought maybe is related.