[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

sdwdate error on whonix gateway startup


#1

I know Whonix for qemu is no longer supported, but I managed to install the VirtualBox images. Everything worked until this morning. Now I get an error because of sdwdate not working on startup of the gateway. I managed to get it running again by restarting a few timee and waiting, but now continously the connection breaks. When I reboot the gateway, I get the same error again.

Please help!!!


#2

using bridges or direct connection to Tor?

also qemu dropped being supported in favor of kvm images.


#3

So you are using Whonix VirtualBox images with QEMU?

If yes: In that case would be far better to use Whonix KVM images and then modify the xml files to be compatible with QEMU but that is unsupported.


QEMU:

KVM:


If no: if QEMU isn’t involved, why mention it?


#4

Thank you for your answers. I had no problems wirh the virtualbox images so far. I use a direct connection to tor. I figured out I get no error when I just restart whonixcheck. sdwdate just seems to need more time to initialize. The unstable connection seems to be related with too less cpus. I changed cpu settings and now it is working again. I will write again if I have new problems.
Happy new year everyone!


#5

Re: sdwdate. Yes - I have also seen this behaviour in the past. Pattern is:

  1. Tor bootstraps 100%.
  2. sdwdate sits for many, many minutes (sometimes hours) doing the “initial time fetching” if you look at the logs.
  3. You can’t use Tor circuits for activities prior to the time sync process. Each time fetching times out after 60 seconds, again and again (and again) and keeps rotating through pool 1, pool 2 etc sources.
  4. Tor logs (sometimes) show a shitload of colapsing circuits, or circuits just waiting to launch (waiting on sdwdate finishe e.g. “we’d like to launch a circuit, but we currently have 32 blah blah ciruits pending”).

Note that this issue is Whonix-specific on the Qubes 4.0 platform i.e. if you run TBB in a Debian 9 VM, it works perfectly and connects within seconds.

Note also that a previous, working clone of sys-whonix will also not connect with the same symptoms - therefore ruling out corruption or unique individual tweaks to the VM that might cause the breakage.

This of course begs the question - Why would TBB work flawlessly in connecting to Tor, whilst Whonix wouldn’t at the same time? sdwdate edge-case issue?

Possiblilities:

  1. Corrupt time sources for sdwdate (Low likelihood)
  2. General network issues (Low-moderate likelihood)
  3. sdwdate coding fault (Low likelihood?)
  4. Poor throughput / misconfigured / malicious / under attack Tor guard set in operation (High likelihood)
  5. Dipshits on the taxpayer dollar personally fucking with your network connection in an effort to have you manually shift Tor guards to one of their poisoned nodes so they can improve their end-to-end and other attacks (Remote likelihood)

Although possibility #5 is considered remote, long term Tor users will note that network activity is often ‘flaky’ or ‘weird’ at X-Mas time.

So this phenomenon could be harmlessly related to increased traffic at that time, or (tin-foil hat) is related to increased spook/other activity during holiday periods (since they believe in Hollywood X-Mas plots in general).