sdwdate and uwt in Arch Linux

Interested in making another OS as safe as Whonix Workstation is. Using Arch linux. Everything is clear except using sdwdate and uwt utilits. I can not install them, even using dpkg. Is there some files with .deb extension to install them using dpkg? Or is there any other solution?
I think using another systems as Whonix Workstation is popular and it will be a good idea to make it clear how to configure it. Especially I think sdwdate is necessary, because you can manually write in program network connections, but time sync has a vulnerability. Or I am not right?
Thank you for attention.

P.S. As Qubes has no forum I will try to ask here: how can I install Qubes as a secret OS using true- or vera-crypt with puting boot sector on usb. So that you put in usb and Qubes loads. And if you don’t use usb your not secret OS loads.

swdate → sdwdate

You found the debs already? Or you did not?

Because when you cannot install them using dpkg, means you had something you tried to install with dpkg, i.e. the debs.

They’re all here:

Any dpkg error messages?

You might want to build them from source instead? Or port them to Arch specific package format? Depending on if this is a personal or redistributable project?

Since I am not using arch linux, I know little about it. No idea how easy/hard it is to get a Debian deb working on Arch. uwt could be more difficult, because it depends on and internally uses config-package-dev.

The answer is “for a stable implementation, you must probably port it to become a native Arch package”. That’s not very helpful, I guess, since that is a development task. Due to time restraints, it won’t be possible for me to make the port. However, if there are specific technical questions regarding the port, I’ll try my best answering questions.

This forum cannot be used as a general Qubes support forum. They have their own support channels. Please see:

I knew only about github pages, there were no .deb packages. Thank you for the link! I really couldn’t find it myself.

It’s just a personal project. As I know nothing about porting, I have to try to install them with dpkg. Now I have deb packages, so I copy thew to /home, because so I don’t need to type the way to the file and type:
sudo dpkg -i uwt_3.1-1_amd64.deb

the mistake is:

dpkg: dependency problems prevent configuration of uwt:
uwt depends on torsocks; however:
Package torsocks is not installed.
uwt depends on faketime; however:
Package faketime is not installed.
uwt depends on libc6 (>= 2.3.4); however:
Package libc6 is not installed.

dpkg: error processing package uwt (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:

Then I try to install all these packages, using:

yaourt -S torsocks
yaourt –S libfaketime
yaourt –S glibs

But the mistake is just the same, as if they have not been installed. No problems with installing packages before, they have installed without mistakes as well. I tried to reboot, but the mistake is the same.

Installing sdwdate also have the same mistakes with some packages, but there are more of them, so I type this.

Does anyone tried it? I think using another OS with Gateway is fare not a rare thing, does anyone had the same problems?

P.S. I understand that it’s easier to install debian, but I need arch tools.

I cannot help with other distribution support due to time restraints. It’s a rabbit hole. Anyone else feel free to discuss this.

Just found : Debtap - A script to convert .deb packages to Arch Linux packages / Creating & Modifying Packages / Arch Linux Forums
i haven’t tried it (not using Arch) but have you testet this ?

1 Like

Thank you.
Perhaps this works. I am not sure because running programs after installation with console doesn’t work, but the installation itself has no problem. Looks like this:

yaourt –S debtap
debtap –u
deptap package_name
pacman –U package_name (with .tar)

When trying to type sdwdate there is such error:

File “/usr/bin/sdwdate”, line 452
print message
SyntaxError: Missing parentheses in call to ‘print’

Trying to fix it with installing sdwdate with apt-get, but there are dependencies, which are not considered to be installed with both apt-get and pacman (like in previous message)…

@Smith If you have dev experience, could I suggest working on interesting problems on our bug tracker instead of re-implementing the wheel?

1 Like

I’m just an ordinary user, not a programmer and don’t understand in porting, but if I can be useful I’ll try, cause I like whonix.

P.S. I don’t think this work is useless, cause many people use other os with whonix. There are a lot of instructions how to use kali or parrot, for example. Don’t know what for, cause it’s easy to install kali tools in debian. The majority just doesn’t think about sdwdate and uwt.

I hope once whonix will use multiple os, lightweight to put gateway on mobile and such as arch and gentoo for workstation to use on pc.

That looks to me like you are trying to run our stable sdwdate version based on python2.7 with the wrong dependency python3. The development version of sdwdate has been ported to python3.