[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

sdwdate and sdwdate-gui development thread

Left click does nothing for me in KDE.
Left click does nothing for me in XFCE.

Right click always works well for me in KDE.
Right click always works well for me in XFCE.

sdwdate-gui looks a lot better in Whonix XFCE!

(Days of KDE version are probably numbered so no KDE fixes required: User Poll - XFCE vs KDE - KDE Deprecation Considered!)

1 Like

Using Qubes-Whonix, stable proposed updates repo.

I noted today that even when sdwdate-gui was telling me “the clock is fast” etc in logs, and the random time-sync stuff hadn’t completed, it was still possible to download updates via sys-whonix for TemplateVMs.

So, there must be some logic flaw, since all updates should have been blocked until sdwdate finished i.e. jumped a random number of seconds forward or backward first.

Never seen that before.

1 Like

Blocking networking until sdwdate finished isn’t a feature which is enabled by default (yet).

Did you apply instructions from https://www.whonix.org/wiki/Network_Time_Synchronization#Block_Networking_until_sdwdate_Finishes?

Sorry, my mistake.

No, I didn’t apply that change - had thought it was by default.

1 Like

Some changes for log viewer, buster, file permissions.

Why is there if self.tor_status == 'running':? What stopping sdwdate has to do whether Tor is running or not? Bug?

1 Like
1 Like

An update to the list of onions used by sdwdate. On boot, it can take ages before sdwdate is ready in sys-whonix, with a whonixcheck popup in some case (Qubes).

I could see that sdwdate-gui is included in whonix-15 VirtualBox, but not in the Qubes flavor. Is it planned after https://github.com/QubesOS/qubes-issues/issues/4117 is implemented ?

2 Likes

Qubes-Whonix sdwdate-gui: it is installed by default but needs to be enabled according to:
Enable sdwdate-gui

It’s not enabled by default due to lack of testing. (sdwdate-gui for Qubes. Testers wanted (developers welcome))
And due to no one around who could fix any python in sdwdate / sdwdate-gui bugs for the time being.

Now that you’re back, we can get back to it.

whonix-ws-15 (DVM Template) based currently throws dom0 qrexec prompt. Same for anon-whonix.

https://github.com/QubesOS/qubes-issues/issues/4117 would be nice but is unrelated.

Could you add an exit (to terminate) button to sdwdate-gui please?

Merged. (two re-added which worked with curl --head)

Maybe only an issue for me. Ignoring.

Hope that made sense?

When saying that sdwdate-gui is not installed in Qubes, I meant not enabled.
To completely enable it, we have to modify /usr/lib/sdwdate-gui/notify-shutdown too.

#!/bin/bash

## Copyright (C) 2018 - 2019 ENCRYPTED SUPPORT LP <adrelanos@riseup.net>
## See the file COPYING for copying conditions

NAME="$(/usr/bin/qubesdb-read /name)"

if [ ! -z "$NAME" ]; then
    /usr/bin/qrexec-client-vm sys-whonix whonix.NewStatus+$NAME" shutdown"
fi

In my version, the qrexec-client-vm command was commented, replaced with true, as in start-maybe.

I am working with a fresh installation, from scratch. The Whonix policies are in dom0.

It’s already in the code, commented. I believe there was an issue with the position of the Exit button in the menu. Will look into it.

1 Like

Done in git master.