[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

sdwdate and sdwdate-gui development thread

Blocking networking until sdwdate finished isn’t a feature which is enabled by default (yet).

Did you apply instructions from https://www.whonix.org/wiki/Network_Time_Synchronization#Block_Networking_until_sdwdate_Finishes?

Sorry, my mistake.

No, I didn’t apply that change - had thought it was by default.

1 Like

Some changes for log viewer, buster, file permissions.

Why is there if self.tor_status == 'running':? What stopping sdwdate has to do whether Tor is running or not? Bug?

1 Like
1 Like

An update to the list of onions used by sdwdate. On boot, it can take ages before sdwdate is ready in sys-whonix, with a whonixcheck popup in some case (Qubes).

I could see that sdwdate-gui is included in whonix-15 VirtualBox, but not in the Qubes flavor. Is it planned after https://github.com/QubesOS/qubes-issues/issues/4117 is implemented ?

2 Likes

Qubes-Whonix sdwdate-gui: it is installed by default but needs to be enabled according to:
Enable sdwdate-gui

It’s not enabled by default due to lack of testing. (sdwdate-gui for Qubes. Testers wanted (developers welcome))
And due to no one around who could fix any python in sdwdate / sdwdate-gui bugs for the time being.

Now that you’re back, we can get back to it.

whonix-ws-15 (DVM Template) based currently throws dom0 qrexec prompt. Same for anon-whonix.

https://github.com/QubesOS/qubes-issues/issues/4117 would be nice but is unrelated.

Could you add an exit (to terminate) button to sdwdate-gui please?

Merged. (two re-added which worked with curl --head)

Maybe only an issue for me. Ignoring.

Hope that made sense?

When saying that sdwdate-gui is not installed in Qubes, I meant not enabled.
To completely enable it, we have to modify /usr/lib/sdwdate-gui/notify-shutdown too.

#!/bin/bash

## Copyright (C) 2018 - 2019 ENCRYPTED SUPPORT LP <adrelanos@riseup.net>
## See the file COPYING for copying conditions

NAME="$(/usr/bin/qubesdb-read /name)"

if [ ! -z "$NAME" ]; then
    /usr/bin/qrexec-client-vm sys-whonix whonix.NewStatus+$NAME" shutdown"
fi

In my version, the qrexec-client-vm command was commented, replaced with true, as in start-maybe.

I am working with a fresh installation, from scratch. The Whonix policies are in dom0.

It’s already in the code, commented. I believe there was an issue with the position of the Exit button in the menu. Will look into it.

1 Like

Done in git master.

Posiiton of exit button is non-ideal but we really need that exit button. Better not having any exit button.

P

Put the exit button at he bottom of the menu.

Ideally, there should be a separator between the last vm and the exit button. Struggling with this.

1 Like

Merged, tested, and available from testers repository. The separation is category “perfection”. Working really, really good already. Much, much better to have an exit button.

We don’t need to trust qubesdb-read /name and can use an environment variable instead.

QREXEC_REMOTE_DOMAIN

I think I need to replace $1 with $QREXEC_REMOTE_DOMAIN in etc/qubes-rpc/whonix.NewStatus or something.

Probably does not work yet.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]