Problems with auto login and bug with KGPG frontend?

Again thank you Ego I would be lost without your kind help and polite responses, you are truly an asset to this forum. I have managed to get everything almost set up for a full switch to whonix except for 2 things. I noticed that the workstation comes with its own PGP client I managed to import my keys to it, yet I can’t seem to find out how to open the page to draft a message to encrypt?? Can someone tell this noob what I am missing or do I need to add something to make this fully functional??

Secondly, I have noticed on the youtube vids when people run whonix it asks for their pw, for some reason ever since I have installed the gateway and workstation it auto logs me in every time. Is this normal?? I believe I have successfully changed the pw yet it has yet to ask me for it when I start the client.

Any help would be appreciated…

Thanks in advance.

kgpg is installed by default. It’s not Whonix’s own client. You can use it the same way like on any linux distribution as per Whonix ™ - Anonymous Operating System. But you don’t have to use it. You can also use gpg command line [most reliable, bug free] or other tools.

On youtube are probably very old versions. KDE autologin is expected. (

Thank you for your help Patrick, I will likely just import a more secure PGP client then, but since I have already imported the keys to the default client does anyone actually know how to open a page to type a message?? Seems silly that it would come with a PGP client with missing a draft page? Has anyone used the default client successfully? How do you open a new page?

There is no “import key to default client”. kgpg is a graphical frontend to gnupg (gpg). It uses the same settings folder as gpg ~/.gnupg.

File -> Open Editor