[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

problems update or hacked whonix-qubes 4.0


#2

Hi whonixbest

This is something that happens from time to time. The good news is, this doesn’t look like you’ve been hacked. Quite often this is something that resolves itself in time.

Taken from wiki Security_Guide

It could be a temporary Tor exit relay or server failure that should resolve itself. Check if the network connection is functional by changing the Tor circuit and trying again. Running whonixcheck might also help to diagnose the problem.

https://whonix.org/wiki/Security_Guide#Updates

Other considerations:

  • Have you successfully updated your R4.0 Whonix templates prior to this?

  • Did you change any network settings recently?


#3

https://www.whonix.org/wiki/FAQ#Am_I_compromised.3F


#4

thanks for the help! now a new problem. can not update fedora 26screen


#5

Hi whonixbest

Since this issue in not Whonix specific you can use the Qubes mailing list to ask for help with updating Qubes (Fedora) templates.

If you do ask for help on the Qubes mailing list it may be helpful to:

  • translate the text in the Fedora terminal to english
  • mention if this is a new problem ( have you successfully updated this template previously?)
  • if you changed any network settings

Also, if you are updating over Tor? You may want to wait a while and try again.


#6

Known issue:

https://github.com/QubesOS/qubes-issues/issues/3737

Fix:

Modify /etc/yum.repos.d/qubes-r4.repo to use https instead of http.


#7

thanks for the tips! the problem decided. There is one more problem. on the picture, the arrow shows that it requires an update. how to update it? as well as the rest template or was peculiar?

Screenshot_2018-04-21_16-24-39


#8

Hi whonixbest

This following wiki page was written for Qubes 3.2 .

If you are using Qubes 4.0, you can disregard setting a NetVM for your template VMs. (Github Qubes issue 1854)

There is also an issue with qubes-manager showing the pending updates available icon (green arrow) when no updates are available. If you have already updated Whonix templates, its most likely due to this bug.

https://github.com/QubesOS/qubes-issues/issues/3743

https://github.com/QubesOS/qubes-issues/issues/2009


#9

I do not understand how to update the tor browser in whonix-vm-dvm?


#10

Hi whonixbest

Updating Tor Browser should be fairly simple

Edited as per Patrick’s followup post

1. In dom0, run Tor Browser in whonix-vm-dvm

2. In the upper left hand corner of Tor Browser, right-click the green onion.

3. Right-click on Check for Tor Browser updates

4. When updates are complete, restart Tor Browser when prompted

5. In dom0, shutdown whonix-vm-dvm

  1. In dom0, run whonix-vm-dvm konsole

    qvm-run whonix-vm-dvm konsole

  2. In whonix-vm-dvm konsole, update Tor Browser

    update-torbrowser


#11

Don’t start Tor Browser in TemplateVM. This is at least what we write here:

https://www.whonix.org/wiki/Tor_Browser/Advanced_Users#Running_Tor_Browser_in_Qubes_TemplateVM

Open to reconsider.

Use https://www.whonix.org/wiki/Tor_Browser#Tor_Browser_Downloader_by_Whonix

This is not yet well thought through / let alone documented. TODO: development


#12

Thank you very much, you helped me. I corrected everything!


#13

Eventually, the (Anondist) Tor Browser package will be updated within the
template with regular updates, right?


#14

I update Fedor 26 and that’s what’s on the screen, what does it mean? all OK?111111


#15

Note:
https://www.whonix.org/wiki/FAQ#Am_I_Compromised.3F

Otherwise, this is up to Qubes support as per:
https://www.whonix.org/wiki/Free_Support_Principle


#16

OMG!!! whot this?

2

1


#17

1st and 3rd pics are not unusual. You often see similar output with Qubes package updates.

2nd pic is a known issue that is fixed in Whonix 14. See:

https://github.com/QubesOS/qubes-issues/issues/3469

It is not fatal to anonymity. If you run:

systemctl status systemd-timesyncd.service

You will see the process is dead ->

user@host:~$ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled)
Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
└─30_qubes.conf, 40_sdwdate.conf
Active: inactive (dead)
Docs: man:systemd-timesyncd.service(8)

@Patrick that error message link above to “whonix.org/wiki/Dev/Design-Shared#timezone” is broken because it doesn’t exist on that wiki page.

PS Jessie is EOL as of 17 June, so I guess we don’t have long to wait for Whonix 14 :slight_smile: ->

https://www.debian.org/security/2018/dsa-4205

Your earlier pics re: Fedora 26 updates and checksums not matching is also not uncommon. As to why - I’m guessing it relates to issues Qubes have had recently re: changing Fedora repos to https, or possibly network attackers at large screwing with downloads over Tor (although I don’t see how it can succeed as an attack vector, if gpgcheck=1 is applied, which it is by default).


#18

I read everything, but did not understand how to solve the problem. Help!


#19

Please use the search function of the forums or search engines to search for error messages. Very likely you’re not the only one affected and very likely has been discuses beforehand. Like in this case. Example search term:

unexpected result by timedatectl


#20

Summary: harmless and fixed in Whonix 14


#21

2 posts were split to a new topic: How to start monero?