problem with Tor Browser in workstation


Hello all,

I have installed whonix on virtualbox. At the beginning, everything was Ok.
But since 2 days, I have a problem with tor.
Everything is OK in the gateway, update, synchronization and all, but when I run Tor on the workstation, it don’t work.
here is the message I have when I run a check:

code: 255
tor bootstrap timeout_type: none
tot bootstrap_status: socket error: [errno 113] no route to host
check_soks_port_open_test: 7
tor circuit: not established

On my host, Tor is running without any problem.

Can someone help me ?

Thanks in advance.



Please don’t substitute writing Tor when you mean Tor Browser or the confusion will be perfect.

check -> whonixcheck

I don’t really know. We can only try to debug this.

whonixcheck does complete successfully on Whonix-Gateway?

Please run the following command inside Whonix-Workstation and post the output in this thread.

bash -x whonixcheck --function check_tor_bootstrap


hello Patrick,

thanks for your answer. Sorry for the Tor but for me tor and tor browser is the same.
Whonix complete successfully on the gateway. Everything is running fine on the gateway.
I run your command inside the Whonix-Workstation.
Here is the result:

Code 255
tor _bootstrap_timeout _type:none
tor_bootstrap_status:socket error: received empty socket content
Tor circuit: not established

On the principal host, Tor browser is running without any problem.




Did you change any settings in VirtualBox or in the VMs?


Please post the output from the terminal (Konsole) window.


It is possible that I made some changes on the network parameters. What are the good ones for the workstation ?


I have made some change in the definitions of the network.

It is working now !

Thanks for your help