Problem with hidden/offline CPUs in Kicksecure/Debian

Good day dear people,

Since I installed Kicksecure on Debian Bullseye (or maybe before?), I have only 2 CPUs instead of 4 CPUs being used by the computer. my computer has a total of 4 real CPUs. 2 CPUs have now been set to offline by the system. i read in another forum that it might have to do with the cpu attack mitigation (spectra and others) that is why those core were hidden. if this is true i can’t say.
do you know this problem? and is this intentional, or is this a bug? Can I turn on the two hidden or disabled CPU again? If so, how? And would that have any negative effect on the protection of my system? Is there anyone here who knows about this?
If you need more information from my system, please tell me what information exactly.
I ask for help!


Not intentional. Could be a bug.

You could experiment with disabling settings in folder /etc/default/grub.d. Changing kernel boot parameters. See also:

Dear Patrick,
thank you very much for your answer!
So you mean this is not wanted and could be a bug?
I am but here in the forum on something stumbled. Could my concern perhaps have to do with the following topic? It seems to me at least so, or am I deceiving me in this regard?

…unfortunately I just realized that I can’t share links here.
The title of the post I am referring to is
[Kicksecure: half the CPUs are shut off - expected behaviour?]

known: no
intended: no
could be bug: yes

You can post links now.


…could be a duplicate.

1 Like

Sounds like a bug. I know one has to go out of their way to make CPUs ignored by the host system - if you’re not seeing all of your hardware on there. If you’re seeing this by default then there’s likely some problem.

In case of the VM, we limit the CPU numbers and even pin it to physical cores for some safety for sidechannel attacks on crypto operations. You can edit the VM settings and remove this if you need to use more cores.

1 Like

ok, but if I understood correctly, these are all security settings of the system, right? So if I disable or change something there, then I make my system vulnerable to various attacks, which these settings should actually block, right? Does that mean I have to choose between fast or secure? Or is there a more elegant way to do this without compromising the security of the system?

Thank you very much for this!

Thank you very much for your answer!
Yes the problem exists on my host system running Kicksecure. So it is not about the virtual machines. I am absolutely not sure what to do about this.