Problem starting Whonix 14 after upgrade? Unable to write to /sys/fs/cgroup/blkio/machine.slice/machine-qemu ...

EDIT by Patrick:
See: Request operation not valid: blkio device weight is valid only for bfq or cfq scheduler.

Original post:

Hi, I had Whonix working until I updated and I didn’t change anything so I’m confused as to why this is happening. I’m using Arch Linux, kernel 5.0.2 and my libvirt version is 5.1.0-1.
Any help or tips are appreciated because I’m pretty lost.

The full error log:

Error starting domain: Unable to write to ‘/sys/fs/cgroup/blkio/machine.slice/machine-qemu\x2d3\x2dWhonix\x2dWorkstation.scope/blkio.weight’: No such file or directory

Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/”, line 75, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File “/usr/share/virt-manager/virtManager/”, line 111, in tmpcb
callback(*args, **kwargs)
File “/usr/share/virt-manager/virtManager/”, line 66, in newfn
ret = fn(self, *args, **kwargs)
File “/usr/share/virt-manager/virtManager/”, line 1420, in startup
File “/usr/lib/python3.7/site-packages/”, line 1080, in create
if ret == -1: raise libvirtError (‘virDomainCreate() failed’, dom=self)
libvirt.libvirtError: Unable to write to ‘/sys/fs/cgroup/blkio/machine.slice/machine-qemu\x2d3\x2dWhonix\x2dWorkstation.scope/blkio.weight’: No such file or directory

EDIT: Every other virtual machine I have is working fine it’s just Whonix I’m having issues with.

UPDATE: I followed the instructions in the similar thread http://forums.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion/t/solved-cant-start-the-new-14-whonix-vms-libvirterror-unsupported-configuration-block-i-o-tuning-is-not-available-on-this-host/5664 but there when I’m compiling the kernel I don’t have a “CONFIG_CFQ_GROUP_IOSCHED=y” option. I have a CONFIG_BFQ one though…and that one is enabled as are the other settings.

Hi cca

When you have an issue its a good idea to use the forum search engine to see if the issue or error output has been reported.


1 Like


I saw that post but their error isn’t the same as mine. They’re similar in that they both happened after upgrading I didn’t see why that’d be the same issue.

and at the end it specifically says to follow those steps if i have the same error.

Hello. This seems to be a bug in the underlying code and not widely reported. I recommend you downgrade to the last working version if possible and to report this to upstream libvirt bugtracker.

1 Like

Hi, I have same issue. I downgraded libvirt to 4.9.0-2 but similar error occurred:

601: error : virCgroupSetValueStr:480 : Unable to write to ‘/sys/fs/cgroup/blkio/machine.slice/machine-qemu\x2d1\x2dWhonix\x2dGateway.scope/blkio.weight’: No such file or directory

I tried to determine a suspicious package upgrade by seeing /var/log/pacman.log but it was difficult due to too many upgrades :stuck_out_tongue:
Most suspicious one would be:

[2019-03-18 14:19] [ALPM] upgraded linux (4.20.3.arch1-1 -> 5.0.2.arch1-1)


sudo virsh edit Whonix-Gateway

then same for ‘Whonix-Workstation’

Strip out this setting:


Then save and try starting the VM. Should work.

It’s obvious blkio.c is missing on Arch for some reason and causes a VM relying on this feature to fail. If you confirm it working I’ll add to the workarounds section on the wiki.

Another solution I saw is to use the fair scheduler in case you want to keep the blktune feature on:

echo cfq > /sys/block/{DEVICE-NAME}/queue/scheduler

Let me know if this works too.

I had the exact same problem on Debian 9 with custom Linux 5 kernels that I compiled myself.

I recompiled the latest stable 5.0.6 kernel following instructions here (although I was also unable to find all exact options).


Still doesn’t work.

Following @HulaHoop’s instructions I edited out the


In the VM settings. Works fine now.

So probably a bug/regression in the new kernel?

Good to know. It’s listed on the wiki.

Most likely. If this continues after upgrade to Buster then I will have to rip it out instead of having new tickets being opened or people giving up.

As far as I know, Buster will ship with kernel 4.19, I don’t know whether this version also has this bug.

No. I’m running with 4.19 from backports here and I haven’t run into it.

See: KVM, troubleshooting: Request operation not valid: blkio device weight is valid only for bfq or cfq scheduler