[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Problem installing Riseup-VPN via Snap

Hello, I have encountered a problem when installing riseup-vpn via snap, in appvm in my qubes os.

I created a minimal debian-11 template and installed security enhancements from the kicksecure team into it, then I installed the packages qubes-core-agent-networking and snapd along with qubes-snapd-helper. After that I started installing riseup vpn with snap install --classic riseup-vpn and at the end I keep getting an error:

user@sys-vpn:~$ sudo snap install --classic riseup-vpn
2022-05-16T22:05:13-04:00 INFO Waiting for automatic snapd restart…
error: cannot perform the following tasks:

  • Run install hook of “riseup-vpn” snap if present (run hook “install”:

Traceback (most recent call last):
File “/snap/riseup-vpn/179/meta/hooks/install”, line 26, in
subprocess.call([‘update-desktop-database’])
File “/usr/lib/python3.9/subprocess.py”, line 349, in call
with Popen(*popenargs, **kwargs) as p:
File “/usr/lib/python3.9/subprocess.py”, line 951, in init
self._execute_child(args, executable, preexec_fn, close_fds,
File “/usr/lib/python3.9/subprocess.py”, line 1823, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: ‘update-desktop-database’
-----)

Maybe someone has encountered this? I’ve already tried installing qubes-core-agent-passwordless-root and different versions of python, but I still get the same error.

Thank you.

Translated with DeepL Translate: The world's most accurate translator (free version)

Try with plain Debian if the same issue is happening. If so → Information Booster might be Available!

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]