[OPEN] controller usb should ommit model=

Getting an error.

Error starting domain: unsupported configuration: ich9-usb-ehci1 not supported in this QEMU binary

I think this is related to the following.

    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x7'/>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0' multifunction='on'/>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x1'/>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x2'/>

Documentation (libvirt: Domain XML format) says:

A “usb” controller has an optional attribute model, which is one of […]

So we should leave the model= out, since it appears to be hardware specific.

Simply omitting


doesn’t do the trick. But I guess we can figure out.

Can you figure out how to omit the “model=” for USB?

Host operating system: Debian stable with wheezy-backports. Version numbers:

libvirt-bin 1.2.4-1~bpo70+1 
qemu-kvm 2.0.0+dfsg-4~bpo70+1 
virt-manager 0.9.1-4

Maybe this is not as big an issue as I thought. Didn’t reboot. Added reboot to documentation.

Nevertheless, since model='ich9-… is host specific, it should be omitted.

I’m not sure its host specific, but probably related to virtual chipset used. the Q35 chipset probably. Its defined as pci-root.

Due to recent pull requests (https://github.com/Whonix/Whonix/pull/241/files) did you conclude it’s best to completely disable USB?

Yes this and also because libvirt auto creates just the controllers needed depending on the devices added.