[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Notifications Prompt on login


#1

Hi @mig5. Every login I am prompted to enable notifications though I have them enabled already. Do you know if this is a discourse bug?


#2

Thanks @HulaHoop. I’m investigating and will let you know.

By Notifications do you mean the ‘Live Notifications’ setting at /u/HulaHoop/preferences/notifications ?

Can you also take a screenshot of the prompt so I can see what you’re seeing?

Cheers


#3

I’m struggling with installing a screenshot utility, however the message appears in a blue box at the top of the page saying"

"Do you want live notifications when people reply to your posts? Enable Notifications. "


#4

Thanks @HulaHoop

My understanding is that this setting is driven not by Discourse but via your browser settings (e.g in Firefox, ‘Notifications’ in about:preferences#privacy . You may need to uncheck ‘Block new requests asking to allow notifications’ or whitelist the forums.whonix.org site in your browser notification settings).

According to what I can see as an admin, in your preferences, your Live Notifications is set to ‘Denied’ with the message “You denied permission for notifications. Allow notifications via your browser settings. Note: You have to change this setting on every browser you use.”

My own settings are the same as above (‘Denied’), but I don’t reproduce the issue. I just enabled Notifications in my browser, and then got the prompt on the forum. I consented to enabling notifications and I don’t get reprompted even in another browser. So I’m not sure why it’s different for you. It suggests that at some stage in the past, your notifications were disabled in browser and so disabled in Discourse. But maybe you’re now using a browser with the notifications on, and so you get prompted - but in fact you ought not to, since it’s clearly set to Denied in your forum preferences.

Hmm. I’ll continue to research if it’s a Discourse bug but I can’t reproduce it.


#5

Actually just realised in my other browser, although the setting was no longer ‘Denied’, I still had to click ‘Enable notifications’ to activate it.

The “Note: You have to change this setting on every browser you use.” suggests that it’s by design since it’s driven by browser settings. If you’re using a DispVM in QubesOS every time you visit the forums (as I am), maybe this is the cause… (a different browser each time)?

Perhaps if I had forums.whonix.org whitelisted in browser settings (including in DispVMs default settings) I would not have to enable it each time… does this match your situation? Are you using the same browser every time without changing browser settings, or different one each time?


#6

Hey @HulaHoop, I just reproduced it again signing in via Tor Browser (which by default allows notifications).

If I even just open another tab I see the blue bubble again.

Furthermore, in my settings within Discourse, nothing happens when I click ‘Enable Notifications’.

But in a regular Firefox browser, clicking the button shows the ‘do you wish to allow notifications’ native box popup in the browser, and I say yes, and the setting sticks.

So, this seems just an issue under Tor Browser…

I’ll investigate if I can fix it, but it’s curious, as it doesn’t show any debug errors that I would expect to see if it was CSP related etc.


#7

Yes I always use Tor Browser with no modifications on my end.

That would be great thanks.


#8

Hi @HulaHoop,

I’ve been unable to solve it - more significantly, I reproduce it on Discourse’s meta.discourse.org as well as their demo try.discourse.org. So the issue is not specific to our configuration, version or infrastructure.

I’ve therefore reported it upstream at https://meta.discourse.org/t/enable-notifications-button-in-user-preferences-doesnt-work-on-tor-browser-8-0-3/101036 with as much info as I can think of.

Cheers
Mig


#9

I got a sassy response telling me to take it up with the Tor Project. I’ll try that too.


#10

Nice, my sassy response to the sassy response was met with a less sassy, and more useful, response.

Tor Browser is based on Firefox ESR. Firefox 52 ESR disabled the service workers & push notifications to make it easier to handle updates.

So it sounds like it’s a limitation of Firefox ESR. Something we can’t do anything about.

I can disable the live notifications prompt (blue bar) entirely if that makes it less annoying/distracting? What do you think? I think I’ll go ahead and do that actually. I think the user might still be able to enable it in their preferences area, if they can actually use it. EDIT that’s indeed the case.


#11

Sounds good. Thanks for taking this up with upstream. I appreciate what you do for us here.