[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

No tor connections on whonix-gateway after host-os reconnecting to the internet (solved)


#1

I use lattest virtualbox under windows 7 with lattest whonix vm (12.0.0.3.2 with updates). Host os connected to internet via router, whonix gateway vm is permanently running on this os (under vbox). Everything works ok, but when connection [host <–> router] breaks and then recovers, after several minutes whonix gateway becomes unusable (no tor connections, no new circuits). only os (whonix gateway) reboot helps.

Connections page on ‘arm’ is empty.

What i tried:
# service networking restart
# service tor restart

Info:
clearnet$ curl.anondist-orig --tlsv1 --proto =https -H 'Host: check.torproject.org' -k https://154.35.132.146
works
clearnet$ ping 8.8.8.8
also works

Therefore i have internet connection on gateway.

Tor browser on host os or any parallel vm (or this whonix gateway after reboot) also works, my connection isn’t censored.

Any help would be appreciable. Thanks.

upd:
‘whonixcheck’ results:
ERROR: Tor Bootstrap Result: Whonixcheck gave up waiting after 120 seconds. Tor Circuit: not established Bootstrapping 25 % done. Tor reports: NOTICE BOOTSTRAP PROGRESS=25 TAG=loading_status SUMMARY="Loading networkstatus consensus"

upd2:
Solved!

  • found warning in tor logs (/var/log/tor): “[warn] Our clock is x hours, xx minutes behind the time published in the consensus network status document (2016-05-31 19:00:00 UTC). Tor needs an accurate clock to work correctly. Please check your time and date settings!”
  • manually adjusted time in gateway os
  • restarted tor

still have no idea how connection host <-> internet was linked with this.