[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Network Time Synchronization failed error

Hi, I receive a Network Time Synchronization failed error when I start up a new AppVM based on whonix-gw-experimental in Qubes 3.0 rc2. The following is a printout from the terminal of sdwdate.log:

Type: “whonix” for help.
user@host:~$ sudo service tor restart
[ ok ] Restarting tor (via systemctl): tor.service.
user@host:~$ tail -f /var/log/sdwdate.log
2350: dispatching DISPATCH_PREREQUISITE (SDW_MODE: startup) (LD_PRELOAD: ): /usr/lib/anon-shared-helper-scripts/te_pe_tb_check
2350: DISPATCH_PREREQUISITE exited 2 | Tor Bootstrap Result: Tor’s Control Port could not be reached. Please report this bug! | waiting…
2350: sdwdate (not timesync!): signal SIGTERM received. Cleaning up…
2350: sdwdate (not timesync!): signal SIGTERM received. Exiting.
7439: Running sdwdate… pid: 7439 | LD_PRELOAD:
7439: sdwdate_preparation: who_ami is set to user.
7439: dispatching DISPATCH_PRE (SDW_MODE: startup): true
7439: dispatching DISPATCH_PRE done.
7439: dispatching DISPATCH_PREREQUISITE (SDW_MODE: startup) (LD_PRELOAD: ): /usr/lib/anon-shared-helper-scripts/te_pe_tb_check
7439: DISPATCH_PREREQUISITE exited 2 | Tor Bootstrap Result: Tor’s Control Port could not be reached. Please report this bug! | waiting…

This is the first time I am trying whonix and the install was based on the instructions at https://www.whonix.org/wiki/Qubes/Binary_Install#First_time_user.3F (which by the way were excellent!). I was also able to update the templates without any errors. I believe that I have everything setup pursuant to the article (below is the experimental setup):

Template: whonix-gw-experimental with NetVM: sys-whonix-gw-exp

AppVM: whonix-exp-app01 with NetVM: sys-whonix-gw-exp

ProxyVM: sys-whonix-gw-exp with NetVM: sys-firewall

I have the same issue with my AppVM based on whonix-ws. Here is sdwdate.log

Type: “whonix” for help.
user@host:~$ sudo service tor restart
[ ok ] Restarting tor (via systemctl): tor.service.
user@host:~$ tail -f /var/log/sdwdate.log
2350: dispatching DISPATCH_PREREQUISITE (SDW_MODE: startup) (LD_PRELOAD: ): /usr/lib/anon-shared-helper-scripts/te_pe_tb_check
2350: DISPATCH_PREREQUISITE exited 2 | Tor Bootstrap Result: Tor’s Control Port could not be reached. Please report this bug! | waiting…
2350: sdwdate (not timesync!): signal SIGTERM received. Cleaning up…
2350: sdwdate (not timesync!): signal SIGTERM received. Exiting.
7439: Running sdwdate… pid: 7439 | LD_PRELOAD:
7439: sdwdate_preparation: who_ami is set to user.
7439: dispatching DISPATCH_PRE (SDW_MODE: startup): true
7439: dispatching DISPATCH_PRE done.
7439: dispatching DISPATCH_PREREQUISITE (SDW_MODE: startup) (LD_PRELOAD: ): /usr/lib/anon-shared-helper-scripts/te_pe_tb_check
7439: DISPATCH_PREREQUISITE exited 2 | Tor Bootstrap Result: Tor’s Control Port could not be reached. Please report this bug! | waiting…

Any suggestions would be greatly appreciated.

Kind regards,

Richard

The short user centric answer is:
You can ignore this for now, because time synchronization is broken anyhow. Will be fixed with Whonix 12.

[hr]

The contributor centric answer is… A lot stuff you can try…

  • Upgrade to Qubes Q3 RC1. That’s what I am working with at the moment.
  • Upgrade to Whonix 11: https://www.whonix.org/wiki/Upgrading_Whonix_10_to_Whonix_11#Upgrading
  • or wait until Whonix 11 is released (announcement through usual channels) which is hopefully very soon
  • time synchronization will still not work as expected then (dom0 interfering with it)
  • check what whonixcheck says

In TemplateVM:

You can also try the following command which I currently test to make time synchronization work in Qubes. (Prevent Qubes dom0 from syncing Whonix VMs clock.)

In ProxyVM (gateway):

Then the ControlPort should be accessible.

Thank you Patrick for the detailed reply.

I’m currently running Qubes 3.0 rc2

Looking at the steps to upgrade, I think I’ll wait until Whonix 11 :slight_smile:

The steps you provided do not work. However, so as to not waste your time we do not need to spend any more time on this. I don’t mind waiting until Whonix 11. I provide the following just as an FYI.

The sudo systemctl enable control-port-filter-python returns a “Failed to issue method call: No such file or directory”. The first two lines of code worked and I have control-port-filter-python sitting in my Home directory. (yes I am running it in the template)

I tried running sudo service control-port-filter-proxy status in the proxy and it returns an unrecognized service (which makes sense since the above did not work).

Kind regards,
Richard

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]