[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Network connection when gateway is not started

When the gateway was not started “update” and “full-upgrade” was still working. There were only some messages that the download of some files was not successful.

Expected. Whonix-Gateway not being started does not disrupt any applications inside Whonix-Workstation, except…

…there is no networking available inside Whonix-Workstation if Whonix-Gateway is not running.

So seems all working as expected?

The applications are starting, that’s OK. The output showed that most of the files were downloaded. The question is, if the files were really downloaded or if it is only a problem with the output messages.

Much more likely so. To test, you can completely disconnect your computer from the internet and probably still get the same error messages.

When I completely disconnect from the internet the output shows no downloads. The update does not proceed. There is only a message: Trying to connect.

Which virtualizer?

In that case, please report a bug as per:

And also please share the logs Whonix-Gateway shutdown versus disconnect internet.

KVM. (No complete sentence necessary. Please remove the dialog “Body seems unclear”)

Without more details, I am not convinced there is any leak here. This applies:
https://www.whonix.org/wiki/Reporting_Bugs#Support_Request_Policy

See also:

In the documentation I found that I should report the bug to the Whonix discourse forums. Where in the forums should I report the bug?

You can post here but detailed steps how to reproduce it and the different looking logs would be required. Otherwise impossible to know what’s going on here on my side.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]