[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

my whonix stops in 5%

#1

(bad english) (google translator )

i tried to run the ‘‘new whonix’’ but he just stop in 5%
i tried everything , but still dont working.

#2

Hi netvor

Its very difficult to help troubleshoot with the limited information you have provided.

What have you tried? Are there any error messages? Did you follow the troubleshooting guide?

Could you please run the following command in Whonix-Gateway and post the output.

whonixcheck --verbose

1 Like
#3

[INFO] [whonixcheck] | Whonix-Gateway | Wed Mar 20 04:01:23 UTC 2019
[INFO] [whonixcheck] Input Detection: INPUT_AUTO=true CLI=true GUI=false
stdin connected to terminal. Using cli output. Not using gui output.
Alternatively, if want to run from command line, but still use the graphical user interface for input, you could add to command line: --gui
[INFO] [whonixcheck] Root Check Result: Ok, not running as root.
[INFO] [whonixcheck] Pin torproject.org certificate: disabled.
[INFO] [whonixcheck] whonix_build_version: 14.0.1.4.4
[INFO] [whonixcheck] whonix-gateway-packages-dependencies-cli: 9.7-1
[INFO] [whonixcheck] /etc/whonix_version: 14
[INFO] [whonixcheck] Spectre Meltdown Test: skipping since spectre_meltdown_check=false, ok.
If you wish to enable this test, run:

sudo spectre_meltdown_check=true whonixcheck
[INFO] [whonixcheck] Whonix firewall systemd unit check Result: Ok.
[INFO] [whonixcheck] Qubes Settings Test Result: Skipped, because Qubes not detected.
[INFO] [whonixcheck] Check Kernel Messages Test Result: Found nothing remarkable, ok.
[INFO] [whonixcheck] check network interfaces Result: Ok.
[INFO] [whonixcheck] Check whonixsetup Result: done, ok.
[INFO] [whonixcheck] Check Package Manager Running Result: None running, ok.
[WARNING] [whonixcheck] Tor Check Result:
Tor is disabled. Therefore you most likely can not connect to the internet.
(Debugging information: Could not find DisableNetwork 0 in Tor config.)
Please close this window and enable Tor using Whonix Setup!
Start Menu -> Applications -> System -> Whonix Setup
or in Terminal: sudo whonixsetup
or manually (If you know about the public Tor network!) and open /usr/local/etc/torrc.d/50_user.conf with root rights
(Start Menu -> Applications -> System -> Torrc) and set:
DisableNetwork 0
Then run whonixcheck again.
user@host:~$

#4

whonixcheck is already explaining to you how to solve it.

Just do that.

Start Menu -> Applications -> System -> Whonix Setup
or in Terminal: sudo whonixsetup

#5

ERROR: Tor Connection Result:
Whonixcheck gave up waiting.
Tor Circuit: not established
Connection 5 % done. Tor reports: WARN BOOTSTRAP PROGRESS=5 TAG=conn_dir SUMMARY=“Connecting to directory server” WARNING=“Connection timed out” REASON=TIMEOUT COUNT=3 RECOMMENDATION=ignore HOSTID=“185F2A57B0C4620582602761097D17DB81654F70” HOSTADDR=“204.11.50.131:9001”
Possible issues:

  • Is the host’s internet connection working?
  • Whonix-Gateway will need a few moments for bootstrapping the Tor network.
  • Do you live in a censored area?
    Recommendations:

Shut down Whonix and try to get the Tor Browser Bundle from https://www.torproject.org working on your host. If you cannot get the Tor Browser Bundle to work, you will most certainly not get Whonix to work either.
The Tor Browser Bundle is great for testing if you live in a censored area. If you need bridges for the Tor Browser Bundle, you will need them for Whonix as well.
2)
Try again: Start Menu -> Applications -> System -> Whonix Check
or in Terminal: whonixcheck
or in Terminal with debugging: whonixcheck --debug --verbose --gui --cli
3)
Use arm, connection page two, to see if Tor is connected:
Start Menu -> Applications -> System -> Arm
or in Terminal: arm

#6

Hi netvor

  1. Do you know if Tor is censored in your area? Could you please try getting Tor Browser working on your host.

  2. If Tor Browser works on your host could you please try creating a Debian VM in VirtualBox and see I you have an internet connection without using Tor Browser.

1 Like
#7

(google translator)

I’m sorry for the time I took

I tested on kali linux the internet and it did not work for some reason

I already tried it in nat and brigde
I tried both more anyway I could not fix this error

#8

Hi netvor

Sorry to hear that. If you are not able to get Tor working in Kali linux then it won’t work in Whonix. If you are not able to connect to the internet with Firefox browser it might be an Virtualbox issue.