[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Msgdispatcher script bug

Running the current stable version (10.0.0.5.5) of Whonix and sometimes I keep both gateway and workstation open while I lock and put to sleep my host system. Sometimes this results in losing connection on the gateway and Reload/Restart Tor doesn’t always fix this. Most likely due to time difference build up while host was asleep. Shutting down and starting the gateway works and a connection will be restored.

Today after waking up my host system and restarting the gateway. I manual ran WhonixCheck + Timesync, after they began every left click resulted in a drop-down menu that was (somewhat) different from the normal right click drop-down menu and this kept happening for 10ish seconds. When I regained the ability to left click I closed every running Timesync/WhonixCheck and I got the following rare condition/bug :

####################################
msgdispatcher script bug.
No panic. Nothing is broken. Just some rare condition has been hit.
Try agian later. There is likely a solution for this problem.
Please see Whonix News, Whonix Blog and Whonix User Help Forum.
Please report this bug!

error_text: title="$(cat “/var/run/msgcollector/$who_ami/${identifier}.titlex”)"
last ewxit_code: 1
#############################################

Wondering if this bug is anything serious.

Not serious. Please see if it still happens in Whonix 11. Either as a tester or when it’s released.

Thanks for the fast replay, the gateway is working again so it seems to be a one-time bug. Will wait for stable Whonix 11 and update if it still happens.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]