[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Mousepad enabling default wordwrap


#1

@Algernon @Patrick I configured Mousepad to word wrap by default to avoid its annoying behavior without. Please include it where appropriate.

Drop the following (new) config file content at /home/user/.config/Mousepad/wrap.scm:

; (gtk_accel_path “/MousepadWindow/word-wrap” “”)


#2

Word wrap and line-numbers are also options I enable normally.
But I could not get it working with the scm files. They don’t change if you enable or disable word wrap. There is a binary file under ~.config/dconf/user which gets recompiled on the fly as soon as you make changes. Configuration is done via dconf or gsettings. It works from the command line. Theoretically it should also work this way: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/desktop_migration_and_administration_guide/custom-default-values-system-settings

But creating a keyfile with:

[org/xfce/mousepad/preferences/view]

show-line-numbers=true
word-wrap=true

and running “dconf update” . Also did not help. Maybe someone else has more luck? I also found some distro scripts that made use scripts and gsettings to change the configuration. Maybe there is a reason for it … So we could maybe also add this to either a postinst script or some other script where it would fit.


#3

security-misc postinst uses

glib-compile-schemas /usr/share/glib-2.0/schemas || true

What I mean to say with that: since we ought to to avoid shipping binary files [1] in source code - it looks like it is a clean way to use postinst to generate such binary files.


Perhaps works for new user only?

I mean debugging/testing this could be equally difficult as compared to https://marc.info/?l=kde&m=141130406809446&w=2 - i.e. new session/new files/new user required?


because:
[1] hard to deterministically reproduce
[2] looks fishy if not deterministically reproducible
[3] extra complexity for searching backdoors
[4] probably more reasons…