[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Looks like a downgrade attack

Hallo, after last update+dist-upgrade I have new bugs

whonixcheck says: installed TB version 4.5, available versions 4.5 4.5a 4.0.8… please run Tor browser updater.

TB updater tells me this: Installed version 4.5, available versions 4.5 4.5a 4.0.8…Looks like a downgrade attack!

One more bug: On tor browser, when I run check.torproject.org and some whatismyIP page, there are different IPs. Before both pages gave me same IP addresses, now they are always different.

Safe to ignore these bugs?

The intelligence of the user is required unfortunately. You shouldn’t learn to blindly dismiss it. Read. Draw conclusions. Act accordingly.

See also documentation:

One more bug: On tor browser, when I run check.torproject.org and some whatismyIP page, there are different IPs. Before both pages gave me same IP addresses, now they are always different.
Not a bug. -> new TBB feature; https://www.whonix.org/wiki/Stream_Isolation

Fixed local version parser in tb-updater:

That will fix tb-updater and whonixcheck issue.

Will land in > 2.0-1, perhaps Whonix 11.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]