[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Keyboard input ignored intermittently

When I disabled USB, VirtualBox says there are inconsistent settings unless I change the setting under System > Motherboard > Pointing device to PS/2 Mouse. I did that but the keyboard sometimes doesn’t respond and I’m not sure if it is related to this setting. This happens with the default workstation or with Ubuntu and seems to happen in both at once, on and off for a while, then it works fine for a while. I have two keyboards plugged in. I’m using VirtualBox version 4.3.12 on Wheezy. This is rather annoying to say the least!

I just checked again, Whonix-Workstation 8.2 comes with USB disabled by default. I am referring to:
Right click on VM -> settings -> USB -> unchecked “Enable USB controller”)

So I don’t know where you could have disabled USB?

I just checked again, Whonix-Workstation 8.2 comes with “Enable absolute pointing device” disabled by default. I am referring to:
Right click on VM -> settings -> System -> unchecked “Enable absolute pointing device”

Two keyboards probably is a rare setup. Removing one could fix the issue. If you want to continue to use both, there must be somewhere a bug in Debian, Ubuntu and/or VirtualBox. Probably not caused by anything Whonix does.

If it happens with VirtualBox and Ubuntu VMs, then you get access to the much bigger Ubuntu and VirtualBox support community. I advice contacting them while keeping the extra Whonix layer out of the question to avoid distraction. See also:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]