[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Issues with tar


#1

Hello, I am following the screenshots to setup Whonix on KVM, and when I run

tar -xvf ~/Whonix-Gateway-*.libvirt.xz

I get an error message

tar: /root/Whonix-Gateway-*.libvirt.xz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

I tried as root and my normal username and I get the same error message. Any ideas?


#2

Hi David888

Do you know which directory you downloaded the Gateway and Workstation images into? If you did not download them into /home/user_name the command will not work.

If this is the problem you can:

cd /path/to/Whonix_images

tar -xvf Whonix-Gateway-*.libvirt.xz
tar -xvf Whonix-Workstation-*.libvirt.xz


#3

Thank you, this worked. However, I’m having another issue.

When I
tar -xvf ~/Whonix-Gateway-*.libvirt.xz

It tells me my disk is full. This doesn’t make sense because I have plenty of space. So I checked the size of the qcow2 file, and it was 100Gb! Why???


#4

Sounds like a host operating system issue with sparse files.

Information on sparse files but no solution:


#5

Shoot, I have no idea how to fix that. I’m using Trisquel as it seems to be the most functional libre OS and was hoping to use Whonix with it. Any ideas/suggestions?


#6

Use EXT4 and you shouldn’t see this. And kudos for going full libreOS