Issues with Flatpaks in Whonix Build Version 17.1.3.1 - Request for Assistance

Dear Whonix Community,

I hope this message finds you well. I am currently experiencing significant issues with using Flatpaks in my Whonix Build Version 17.1.3.1. (in Oracle VirtualBox Version 7.0.18 r 162988) These problems were non-existent in Whonix 16 and only started after I performed a fresh installation of Whonix 17, as the release upgrade option had failed for me.

Description of the Issue
After upgrading to Whonix 17, I encountered failures when trying to install Flatpaks using the standard commands to add the Flathub remote and install applications. As a temporary workaround, I used the torsocks command, which allowed me to install Flatpaks successfully. However, the installed Flatpaks (such as Bitwarden Desktop, Tutanota Desktop, FreeTube, and NewsFlash) are unable to access the internet, rendering them essentially useless. Interestingly, the only Flatpak that is functioning correctly is Session Desktop, which can send and receive messages.

Troubleshooting Steps Attempted
Using Tutanota Desktop as an example, here are some of the steps I have tried so far to resolve this issue:

  • Checked Flatpak Permissions:
    Ensured that the necessary network permissions are granted to the Flatpaks.
flatpak override --user --filesystem=~/.tor --share=network com.tutanota.Tutanota
  • DBus and Proxy Configuration:
    Adjusted DBus permissions and tried manual proxy configuration.
flatpak override --user --talk-name=org.freedesktop.DBus com.tutanota.Tutanota
  • Running Without Torsocks:
    Attempted to run Flatpak applications without Torsocks.
flatpak run com.tutanota.Tutanota
  • Updated Flatpak and Applications:
    Regularly updated Flatpak, its runtimes, and the applications.
flatpak update
  • Log Analysis:
    Analyzed system logs and Flatpak logs for any error messages.
journalctl -xe
   flatpak --log-session
  • Flatpak Networking Test:
    Tested networking functionality of Flatpaks explicitly.
flatpak run --command=sh com.tutanota.Tutanota -c "curl https://example.com"
  • Environment Variables:
    Ensured environment variables were correctly set.
flatpak override --env=HTTPS_PROXY=socks5h://127.0.0.1:9050 com.tutanota.Tutanota
  • Reinstallation of Flatpaks:
    Uninstalled and reinstalled Flatpak applications to rule out corruption.
flatpak uninstall com.tutanota.Tutanota
   flatpak install flathub com.tutanota.Tutanota

Unfortunately, none of these steps have resolved the issue.

Request for Assistance
Given my limited technical expertise, I am reaching out to inquire if others in the community have faced similar issues and what steps they took to rectify them. Additionally, I would like to know if a complete deletion and reinstallation of Whonix 17 would potentially solve the issue, even though this would be quite inconvenient as I lost all my content and progress during the initial reinstallation.

Importance of Flatpaks
Using Flatpaks is crucial for my workflow, and I am trying to adapt to the Whonix environment. I understand that some community members might not fully endorse the use of Flatpaks within Whonix, but they are an integral part of my productivity.

Conclusion
I would greatly appreciate any guidance or suggestions you can provide. Thank you for your time and the continuous support the Whonix community offers.

At time of writing, no flatpak overrides should be needed and the only documentation so far on Flatpak is here:
Flatpak
(Doesn’t look this issue is related to not reading documentation.)

Do other Flatpak applications work? Such as Firefox? Usually discouraged in contect of Whonix as per Other Browsers but this would be a useful test to find out the root cause of this issue.

What is suspecting could be geo-blocking. In this context, servers blocking connections from the Tor network. For more information on what that is and potential workarounds, see:

Hello Patrick, thanks for sharing. I eventually uninstalled and re-installed Whonix and it solved the above issues. :face_with_raised_eyebrow: