[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Issues Importing Whonix VM temps


#1

Here is what I have in my terminal right now and I don’t quite understand what is going wrong. It appears that the command Virsh cannot find the gateway .xml file.

asdf@asdf-VirtualBox:~$ sudo virsh -c qemu:///system define Whonix-Gateway*.xml
error: Failed to open file ‘Whonix-Gateway*.xml’: No such file or directory

The .xml is sitting in my downloads folder, and i tried moving the directory to the downloads folder but the same thing happened. Also if it helps I’m pretty much following the guide step by step(https://www.whonix.org/wiki/KVM). This issue is probably has more to do with my lack of understanding of KVM than it is an error or a bug but nonetheless it is stopping my progress.


#2

Hi. Try moving the archives to your home folder before performing the extraction and import steps.


#3

I don’t know if this makes a difference but Whonix-Gateway*.qcow2 and Whonix-Workstation*.qcow2 unpack to 107.4 GB each even though I have only allocated this Linux virtual machine 33GB to use. I tried what you suggested and got this as my output.

asdf@asdf-VirtualBox:~$ virsh -c qemu:///system define Whonix-Gateway*.xml
error: Failed to define domain from Whonix-Gateway-13.0.0.1.1.xml
error: invalid argument: could not find capabilities for domaintype=kvm


#4

Good day,

The size is actually explained here: https://www.whonix.org/wiki/KVM#Moving_Whonix_Image_Files

Have a nice day,

Ego


#5

asdf@asdf-VirtualBox

There’s your problem. You are trying to run KVM nested inside VBox. That’s not tested and unsupported. You are probably seeing a VBox bug. Please consult them.